C2RCC batch processing

I am trying (without success!) to perform the following steps as part of a batch process using GPT:

  1. Read in file
  2. subsample all bands to 10 m
  3. do c2rcc processing
  4. use multi size mosaic to select the bands I want (conc_tsm, iop_bpart and iop_bwit) for a reduced area (I guess I could use subset instead to do this?)
  5. output results to geotiff.
    Unfortunately I can only seem to get steps 1-3 to work within the xml file.
    I think it is something to do with the c2rcc step since I can get the whole process to run if I replace step 3) with somethings simpler (such as subset to just extract a single band).
    The error I get when I run the batch file is:
    Undefined symbol ‘c2rcc_flags.Valid_PE’.
    As a work around I have managed to update the xml file to output a dim file after the c2rcc step and then I can manually complete the process in SNAP (which works fine but it would be great to get it all working in the batch).
    Any pointers would be really appreciated!


You don’t need to use the multi-size mosaic. You have resampled the data already to a common resolution in step 2. You can use the default mosaic.

Can you show your graph XML files you use? I tried mosaicking with an already resampled product and it worked. I used only one as input but should be the same as with multiple products.

Thanks so much, after I posted I tried replacing the multi size mosaic step with subset and managed to get it to work, I will also have a go with mosaic as it would be nice to be able to combine multiple tiles to one output (although finding a way to automate which files should be combined-I guess based on the date information in the filename-may make this more trouble than it’s worth - I am mainly interested in small areas for a large number of timesteps rather than having a large area for a small number of timesteps), I have attached my working xml.graph4.xml (2.0 KB)

1 Like