C2RCC MSI can't be added to the graph

Dear All,
When I want to batch process the L1C data with C2RCC MSI through graph builder, I can’t find this C2RCC MSI in the graph. I add the C2RCC MSI in the .xml file, load it into graph builder, set the parameters, and the following error occurs when exporting.

c2rcc.msi BaseOperatorUI: no converter found for parameter SOURCE_PRODUCT

Kindly help

Unfortunately, C2RCC can’t be used with the Graph Builder. The Graph Builder does not support all features the Operator needs.

Thank you very much for your reply. How do I do the C2RCC MSI batch processing?

You can do it from the command line. There is a guide which explains how to do it:
Maybe it is possible to use a once created XML file in the Batch Processing GUI even if it contains the C2RCC. I’m not sure. I have never tried it.


Thank you very much for your help.

Dear Marpet,

When I was running the graph with gpt, an error appeared:

Error: [NodeId: c2rcc.msi] Operator ‘C2rccMsiOperator’: Unknown element ‘useEcmwfAuxData’

How do I fix it?

In this case you do not have the latest update of the processor.
Go to Tools / Plugins and check for updates to be installed. By the way, you should have SNAP9 installed.
But how have you created the graph? If you have used the same version, it should work.
Do you have two versions of SNAP installed?

Thank you very much for your reply, the problem is now solved.
I removed the aerosol and air pressure parameters and it does not report errors, and the two parameters are automatically added during processing.