C2RCC OLCI Processor SZA error

I have installed C2RCC V0.14 plugin with SNAP4.0.2. When I try to run the OLCI processor using all default settings and none of the optional settings, I get an error

Invalid source product, raster ‘SZA’ required”

This looks similar to a previously solved problem related to view angles.
I realise the C2RCC processor is still in pre-release. I’m not sure if this is a bug or my mis-use of the plugin.

thanks, Jenny

I just tried it myself and it worked.
Can you check if you have chosen a proper source product and if it contains the SZA tie-point grid. Also please check if the correct plugin is installed. Open the processor and open the about dialog (Help–>About). There you should see version 0.14.

Thanks Marco,

It turns out that the mini files that we get for the LJCO ROI do not contain SZA, OZA etc in the tie_geometries.nc
I have tried it on a full L1B scene and it works as you also found. So, definitely a data problem, not a software problem.

Cheers, Jenny