C2RCC product save issue

Dear Experts

I am trying to process S2 using SNAP C2RCC atmospheric correction model. However, when I choose save target product in C:\Users\Sidrah\documents\sen2cor directory the bellow error msg appeared.


and If uncheck the save the product, C2rcc process run correctly but I am unable to view the product and save it in Tiff format. The below msg appear if I try to view the rhow bands.

and saved tiff is blank image.

Is there any problem with the installtion? as this was running correctly earlier.

Have you added the water_confidence_mid mask to the valid pixel expression?
Maybe your input product does not have it?

Thank you for your reply Marpet. I am using Level 1 sentinel-2 data for processing.

But in your first screenshot I see the name of a Landsat product. Maybe you mixed something up?
I just did it. It worked for me.

Now, I see that you are still using an old SNAP version. The icon is from SNAP 7 and before.
Updating to the latest SNAP 8 might solve the issues.

1 Like

Thank you Marpet, new version worked properly.

1 Like