Calibration error S1A dual-pol image

Hello developers!

We’re experiencing problems while calibrating the following Sentinel-1A product:

In particular we did:

  • orbit correction (precise)
  • deburst

Then we tried using Radar – Radiometric – Calibrate.
The process starts but then gives two types of errors, don’t know how to reproduce the different errors. Such errors are:

Calibration: -1



We tried the aforementioned processing on the whole image and also on a subset, with the same results. We also tried on a Linux Ubuntu 14.04 machine with 16 Gb of RAM and on a Win 8 laptop with 8 Gb of RAM (only the subset), with the same results.

In the following I report the log when the “Calibration: -1” error occurred.
Any clues on what it is happening?
Now we try to invert the first steps (i.e. we’ll do first deburst and then orbit correction). I’ll report on that.
Many thanks in advance.


org.esa.snap.core.gpf.OperatorException: Calibration: -1 at org.esa.snap.engine_utilities.gpf.OperatorUtils.catchOperatorException( at org.esa.s1tbx.calibration.gpf.CalibrationOp.computeTile( at org.esa.snap.core.gpf.internal.OperatorImage.computeRect( at at Caused: org.esa.snap.core.gpf.OperatorException: Calibration: -1 at org.esa.snap.core.gpf.internal.OperatorExecutor$GPFImagingListener.errorOccurred( at at at at at com.bc.ceres.glevel.MultiLevelImage.getData( at org.esa.snap.core.gpf.internal.OperatorContext.getSourceTile( at org.esa.snap.core.gpf.internal.OperatorContext.getSourceTile( at org.esa.snap.core.gpf.internal.OperatorImage.computeRect( at at at at [catch] at

This could be related to a similar problem with the noise vectors where
the vectors in the product are not the same size.
We’ll have a look and make it more robust.

Do you mean “the same size” between the two polarizations?

We also tried to calibrate only one band singularly, but same problems.
This way we got another type of error: NullPointerException, on VV polarization. On VH we get the OutOfBounds one.

I can also report now that using deburst+orbit correction gives the same result as orbit+deburst.

So basically we cannot work on calibrated data for now using this image?


It is a bug in deburst which affects the calibration of debursted S-1 SLC product. The bug has been fixed. Thanks for reporting the problem.

Many thanks.
So basically the answer to

at the moment is BEFORE debursting?
And after a new release we could calibrate both BEFORE and AFTER debursting?

Many thanks again!