Calibration in PolSARpro problem

Thank you for the feedback - could you list which dual-pol decompositions you would like to see in SNAP?

1 Like

Krogager, Cameron, Huynen, RVOG inversion, Stokes parameters - degree of polarisation, and for L frequencies Faraday correction

1 Like

Hi everyone !!
So the Snap can use to discover the marine flood and to detect humidity in the mangrove forest ??? Because I think that all these treatments are served at Polsarpro, so that I, too, fall into these errors like that of our friends. What options do I use in the snap?

Thank you all


I tried to use the Tomogram function in PolSAR pro 5.1 , can anyone tell me what do I take as input ? Co registered time series TerraSAR-X or individual time series imageries ?

I also tried the TomSAR module but wasn’t successful with it. I get a runtime error at some point
Did you already see this tutorial?

this is not an error. Please go through the tutorials first.
Here I provided a short instruction list on how to read data: Help installing PolSARpro software step by step on detailed on the windows 7 system

MEANS before the tom-sar processing, we need to follow the steps for all datasets as said inthe above link?

absolutely. PolSARpro needs to “extract” the images first, that means that it converts them in a format which is suitable for the processing.

i did this exactly and again i am facing the same issue, after extraction when i am processong tom-sar

again, this is only a warning. Just click on Yes and proceed with the image extraction.

why did you chose the folder /new instead of the folder where you originally extrated the data?

since i had to extract two or more different time series images to be used for tom_sar later on, i extracted them into seperate folders

for me it worked like this:

  1. Extract image 1
  2. Extract image 2
  3. Add both extrated images in the "Multi Data Sets (Pol-TomSAR) dialogue
  4. The Polarimetric Tomography menu appears

Any solution to this ?

Ok done till step 4 but now it’s saying config file not found, any idea why this error ?

i am getting an error message in polrimteric tomography function when i am selecting my bmp file to select area. what do i do? any idea why this error?

I tried again and am still not getting any results. So I will share the steps I undertook with two ALOS PALSAR QuadPol scenes so we can maybe together find out how to proceed:

I followed these tutorials and documents:

1. Create working directory “Single Data Set (PolSAR)”

I select the folder where the original data is stored and click “Save & Exit”. I confirm the upcoming message and proceed with the file import.

2. Import the scene

I select a different (by now empty) output directory so the imported data can be stored here seperately in PolSARpro format
I select the LED file and click “read header”. Everything is fine so far. I confirm with “OK”. Message “Dont forget to extract the data.”

3. Extract the data

I select some subset coordinates and click on “OK”

A valid pixel mask and an RGB image are created

4. Repeat steps 1-3 with second QuadPol scene

I do the same with the second data set, I select a different output folder so both images are stored seperately.
Set the environment, load the data. Extract the data. I now have two folders with PolSARpro products.

5. Load both scenes for the TomSAR processing

Environment > Multi Data Sets (Time Series Data / Pol-Tom SAR)
I first select the first folder, then click “New” and add the second folder. So I have 1/2 and 2/2. I select the S2 matrix and click “Save & Exit”

6. Start the TomSAR dialogue

Load > Polarimetric Tomography
I get asked for a BMP file so I select one of the two generated Pauli RGBs

7. Generate DEM files

I enter DEM values and click “Gene” in order to generate DEM files. I select the checkboxes in the subsequent windows and click “Run”.

8. Display coherence map

DEM files are now generated and I start the coherence map generation

Results are looking great

9. Run it with DEM compensation

Checkbox “DEM compensation” then “Run”.

Here I get a runtime error and don’t know why

I also don’t know where to check for more detailled error messages. So I can’t go on with the profile analysis as described in the tutorials.
Running the analysis without the DEM compensation leads to the same error message.

So if anyone is able to add some ideas to this, I would be glad about a discussion.

  • Is the process of importing the data correct?
  • Do I need to co-register the data in a way?
  • Do I miss a crucial point in the TomSAR dialogue?

Is it possible to do tomsar with dual pol ALOS PALSAR 1 data?

technically, Dual-Polarization ALOS-1 is supported by PolSARpro but I’m not sure if two polarizations are sufficient for proper tomography results.
Maybe the theory part of this introduction clarifies this:

Please also consider that you need a few images at least.

Thank you…can you please help me how to create the Kz file and flat earth removal file for this data.While trying PCT, I got some problem