Cannot automatically download SRTM3sec

I am trying since yesterday to mask the sea out of a Sentinel-1 image using SRTM3sec, but the DEM cannot be automatically downloaded. I tried using SNAP 7 on Linux environment and using SNAP 8 on Windows, and it failed. SRTM1sec though could successfully be downloaded (but is not the one necessary for the masking operator).
When I manually tried to download the tiles I needed from SRTM Data – CGIAR-CSI SRTM to place them in the correct path, the files were corrupted.
At the end, we do not know how, after several people tried on different devices, SNAP managed to automatically download the SRTM3sec on a windows installation, we copied those files and placed them in the rest devices to proceed with the processing.
It still is not working on Linux environment though.
Could someone please let us know what may cause these errors, which should be the link where SNAP retrieves SRTM, if it differs from the one version to the other, and in case we need to manually download the DEM files we need, which is the website we should visit?
Thank you very much for any advice you may have

could it be related to this FAQ? A process related to digital elevation models is taking forever to finish

After a clean update all functionalities should work. If not, please provide a clearer description of the error you encounter. For example, if you receive an error message.

As an alternative: You could use “Add elevation” to add SRTM 1Sec data to your raster and manually mask land/sea pixels based on the valid pixel expression in the band properties.

The location from which SNAP retrives SRTM3sec is:[zip_file_name]
(accessible using a specific zip file name at the end, e.g.

As of January 2021, SNAP 8 doesn’t use the CGIAR Amazon bucket, but the one @oana_hogoiu has pointed out. The SNAP 8 instances (not 7) that you have tried, were they up-to-date with all the updates?
Regardless, for both SNAP 7 and 8, you could check the actual URL used: in the SNAP installation folder, ‘etc’ subfolder, the file should have a key named [DEM.srtm3GeoTiffDEM_HTTP]. Replace the existing value (e.g. with, save the file and restart SNAP. I’ve tried this on a clean SNAP 7 installation and it successfully retrieved some SRTM 3sec tiles.

Thank you all for the information! SNAP 8 was updated but was not working, after several efforts it just managed at some point to retrieve SRTM 3sec. For SNAP 7, I replaced the link with the one you mentioned above and it is now working too.

Hi everyone,

After 2-3 days of fixing (reading forum suggestions, changing many times, creating and deleting envs), I am still facing this issue and it’s starting to get on my nerves. :rofl: So, I would really appreciate some help.

First of all, I am working on Ubuntu 20.04.2 LTS (GNU/Linux 5.4.0-72-generic x86_64) server, which has no GUI (this is my first-time experience with other OS than Windows, since I am a Windows child).
I created anaconda environment with python=3.6, activated it and installed snap via command conda install -c terradue snap. That created snap version 7.0.0. When I try to do terrain correction, it just doesn’t want to retrieve DEM. Here is the output.
slurm.2484.err (9.9 KB)

  1. Do you have any suggestions?
  2. Is there alternative (better) way to install snappy on headless Linux machine and how?
  3. How can I update snap to 8.0.0? Though snap 8.0.0 exists on “”, it didn’t want to get installed at all with python=3.9.

Relevant piece of my code

parameters = HashMap()
parameters.put('demResamplingMethod', 'BILINEAR_INTERPOLATION')
parameters.put('imgResamplingMethod', 'BILINEAR_INTERPOLATION')
parameters.put('demName', 'SRTM 3Sec')
parameters.put('pixelSpacingInMeter', 10.0)
parameters.put('sourceBands', 'Sigma0_VV,Sigma0_VH')
parameters.put('nodataValueAtSea', False)
parameters.put('alignToStandardGrid', True)
target_2 = GPF.createProduct("Terrain-Correction", parameters, target_3)