Cannot change Performance Options

I seem to be unable to change the Cache Path, or indeed any Performance option.

When I start SNAP 5.0.0, click on Tools->Options and in the dialog choose the Performance tab, I observe that the OK button is enabled:

However, any change in any of the values disables the OK button. For instance, once I start editing the Cache Path entry by removing the leading ‘C’ …

… the OK button is disabled and stays that way, even when closing and re-opening the Options dialog.

The only way to re-enable the OK button is to restart SNAP entirely.


If you want to change the performances of SNAP you can
try to look in the snap.conf file which should be somewhere
in the folder snap was installed (mine is in SNAP/etc/).
to increase the memory snap uses change the -J-Xmx to the value you want.

That is all I can say about it.
good luck,

Yes, well – but there is no entry for the Cache Path in snap.conf, is there?

And the default_userdir entry doesn’t help me either: I changed that to D:\, where I had moved my user specific .snap directory, but on start SNAP just re-creates the old {HOME}\.snap directory.

And anyway: why can’t I change any settings in the Performance Options? Any edit disables the OK button! That’s a bug, in my book! I mean, even if I let the program Compute the best system parameters, the values are written to the edit fields, but the OK button is disabled. Looks like the program not only doesn’t trust the user, it doesn’t even trust its own judgement…

sorry only a new user…I was just only suggesting what allowed me to change
some of SNAP settings.


thanks for reporting Christian, as you said, it is a bug. We have already an issue about this:

1 Like