Cannot connect to the SNAP server both in UK and ASIA

Hello everyone I met this annoying issue with server connection,looking forward to solution.
I downloaded SNAP Desktop in ASIA,but when I entered the worldview panel,
I could not load detailed map when I zoomed in.Then I tried to operate the range-dopper terrain
correction operation,and it stucked when writting data that requiring auto download.
I believe the problem is related to server connection.but now my friends in UK meet the same
problem, I wonder if there is anything wrong with the server now?
Thank you!!

Today I can’t visit Sentinel Open Access Hub and can’t download any sentinel data, both at my office and at home, I wander what has happend to the Internet connection.

This is strange. Because these are two different servers. The word view uses some NASA server and for downloading the DEM ESA servers are used. For me the word view and the DEM download work. This must be coincident or something at your side is not working.

I just tried to download data and it works:

For such issues you better directly contact the Sentinel Open Access Hub.
This is the support mail:

Thank you marpet for your kind reply. However I still cannot complete my writing target product operation.
I checked my Proxy Setting in Option/WWW, and found that the Test connection result was always failed.
If SNAP connects successfully, the test connection result should be some green success sign right?

Yes, I would also assume that success is reported.
Have you tried the manual setup?

If this still doesn’t work, try what is I have just added to the FAQ:
I’m behind a proxy and having difficulties connecting to servers. What can I do?