Cannot download orbit file

I build software for automaticly download and generate VV and VH from Sentinel 1 data.
Use ESA SNAP with .xml script and run it with gpt

Script get .zip Sentinel 1 image and generate from it VV and VH layer automaticly for each image per day.
For old image all works perfectly but for new image (from yesterday and for previoud two weeks) is a problem with orbit files.

Error from ESA SNAP gpt:
WARNING: org.esa.s1tbx.sar.gpf.orbits.ApplyOrbitFileOp: No valid orbit file found for 12-FEB-2021 04:35:05.318396
Orbit files may be downloaded from https://qc.sentinel1.eo.esa.int/
and placed in C:\Users\marcinkrupinski.snap\auxdata\Orbits\Sentinel-1\POEORB\S1A\2021\02
WARNING: org.esa.s1tbx.sar.gpf.orbits.ApplyOrbitFileOp: Using Sentinel Restituted C:\Users\marcinkrupinski.snap\auxdata\Orbits\Sentinel-1\RESORB\S1A\2021\02\S1A_OPER_AUX_RESORB_OPOD_20210212T064648_V20210212T022225_20210212T053955.EOF.zip instead

It is possible to repair it and not must manualy upload this file to catalog?
And test it on ESA SNAP 7.0 and ESA SNAP 8.0

precise orbit files are processed with a delay (around 20 days after image acquisition), so it is very likely that the one for 12th of February 2021 is not available yet.

grafik
source

1 Like

Hi @ABraun,

So when snap2stamps shows the warning reported by @lazyspot, does it applies restituted orbit files or not even that?

Thanks.

not automatically, you have two options

  • download them manually
  • change the script to restituted orbits
1 Like

Thanks @ABraun, but for which reason when I do the apply orbit file with SNAP it seems that the precise orbit files are applied correctly? (also with “do not fail if new…” unchecked) Instead with snap2stamps i got this warning message.

did you install the latest update?

1 Like

@ABraun yes the last version of SNAP, and if I see in metadata seems that the precise orbite file (POEORB) are been applied after SNAP Apply Orbit File. Also on ASF ALASKA website (https://s1qc.asf.alaska.edu/) the POEORB of my data are presents. However, I’m doing a PSI analysis, could the difference between restituted and precise orbite files be important in this analysis or not?

Maybe only GUI SNAP is been updated and the GPT not?

Ps. I have this problem in snap2stamps with data acquired from March 2021. No problem with data until this date.

That is unlikely, both use the same libraries.
Is it for data from the last days? Precise orbits have a delay of around three weeks.

Still, the quality should be sufficient for PS approaches.

Yes the problem is for the data from the last day, but for example, a processing with a data of 20210414, it works on SNAP GUI, but not with snap2stamps. But the precise orbit file there are on the ASF ALASKA database. It’s very strange.

Metadata after Apply Precise Orbite file by SNAP GUI, it seems that’s worked fine, not?

Looks alright, yes. It was reported that there are still problems with orbits retrieved by snappy, but snap2stamps uses the GPT so I can’t think of where the error comes from.

1 Like

I’ve see about snappy, I don’t know because also snap2stamps has these problems.
However, for my PSI analysis, if you confirm that also with restituted orbit files I can obtain good results I will use them. Setting restituted on project.conf of snap2stamps, no warning messages, so only with precise orbit files there are problems.

1 Like

I am a little late to the party but I found that the python pySAR package is great for downloading precise orbit files. It finds all the files and downloads them into folders with the same structure as snap expects (C:\Users\me.snap\auxdata\Orbits\Sentinel-1).

from pyroSAR.S1 import OSV

osvdir = r’\OrbitFiles\S1’

with OSV(osvdir) as osv:
files = osv.catch(sensor=‘S1B’, osvtype=‘POE’,
start=‘20170101T000000’, stop=‘20210501T000000’)
osv.retrieve(files)

I tried out using the restituted files instead of the precise ones in using the gpt modul in the command line as well as in the SNAP GUI for the files I downloaded from the ASF ALASKA website. But I get the same error as Giova.

When I try at the SNAP GUI for the second time it surprisingly works. Could it be that there is a bug wich starts the process first and then correctly downloads the data? (It doesn’t seem to work with the gpt command thogh)