"Cannot find vector scl_nodata" error in supervised classification

Dear all,

We are trying to perform a supervised classification (currently using the Random Forest Classifier, but the same error occurs using other classifiers) using geometries including our training areas.
However, when we select the “Train on Vectors” option, the Training vectors are not shown in the dialogue, instead we get the error message: “Error: [NodeId: Random-Forest-Classifier] Cannot find vector scl_nodata::S2A_USER…”
Actually, the mask “scl_mask” exists, but this is obviously not what the program is searching.

Where did we go wrong? Any help would be appreciated. I found related topics like this, but it doesn’t seem to help here. We tried it on old and new version data, with the same error. I use the the latest version of SNAP (SNAP 5.0) and s2tbx (5.0.1).

Thank you!

It seems the supervised classifier assume that there is a corresponding vector data for each mask. This is not the case for the S2 data.
Maybe it works if you remove all masks except those which were created for your vector one, two and three.

@lveci Can you have look?

The initial use case was to use shape files imported into the products vector nodes as well as using user generated polygons also saved to the vector node. Therefore, the classifiers are only looking at vector nodes and not masks.
It will need further development to use masks. I’ve added an issue for this.

Dear @lveci, dear @marpet,

thanks for looking into this.
Unfortunately, also after trying several options (removing all other masks, importing vectors, generating vectors in SNAP, saving vectors with data set,…), the error message remains the same and no vectors are shown in the dialogue. See also the screenshot below:

Please let us know when this function will be available. Thank you!


Dear All,
Anyone can advise on to proceed with the random forest classifier?