Cannot open img - snaphu

If I type just snaphu I get the same. Could it be because the image is too big ?


But now I tried using cygdrive and apparently it works ( so far). So maybe something wrong happened in the virtual machine (in the settings or so).

Anyway…either I use vmware or cygdrive…It should not change the final output right?
And about those 84 lines…is it normal? because I see this number often in the forum and I thought that the number of lines changes for every processing

the 84 lines refer to the config file not the lines in the image. So this number doesn’t really matter.

Anyway, good to hear it works in cygwin. It should deliver the same result as in the virtual machine. If it takes too long, make a smaller subset of your image before exporting and increase the number of tiles (can be edited in the config file). If you have more processors, you can also increase the number of processors in the config file.

Hi All,

Sorry for the simple question…
When exporting and unwrapping an 8 Interferogram stack (split_Orb_Stack_deb_ifg_flt_ML) in Snaphu, is only one phase unwrapped?

I have managed to unwrap the data and re import to Snap. The resulting product contains all of my original phases and only 1 unwrapped phase. So is this an averaged result?

Thanks in advance

unfortunately, shaphu unwrapping only takes one image pair as an input.

Yeah Ok that makes sense.
Do you think it would be possible to Split the stack, export and unwrap, and then re-stack the unwrapped products? Were you looking at doing something like this in another thread? @ABraun

I was asking the same thing here because I wanted to have a stack with multiple interferograms which are all aligned to the same master but with short temporal baselines (AB BC CD…): Interferogram averaging for DEM generation

Currently we are not supporting stacks with one common master and multiple slaves but it is in our roadmap for the development. Regarding phase unwrapping indeed snaphu is unwrapping only single interferogram. You could try to unwrap in snaphu one by one, import to SNAP and stack, in theory shall work but I have never tired it

Hey all,
furthermore to above, I have another unwrapping question…
Is there any way to control which band (in a stack) is exported? I tried splitting the stack but when you re-open the separated products the slave metadata is lost and therefore (i believe) this stops you from exporting to SNAPHU.
Alternatively, I considered editing the conf file but have no idea how to calculate the “SAR and geometry parameters” nor do i wish too. My objective is to have several unwrapped interferograms over my ROI with a common master.
Any ideas would be greatly appreciated.

I am very new to Ubuntu in vmware and Ubuntu in general. I want to perform 2D phase unwrapping but I am stuck at the Snaphu bit. I followed the esa tuitorial and was able to successfully do a snahu export on SNAP. In Ubuntu, I have been able to do install SNAPHU as shown in the step 1 of the image below. However, I am comletely clueless on how to open my product as shown on step 2 (same image). Kindly guide me where you got the " /mnt/hgfs…_flt$snaphu… img 21733" typed on the terminal. Thank you.

snaphu.conf contains the command which you execute in the folder where you exported the phase. It converts it into an unwrapped phase and stores it into an img file. The corresponding header (hdr) is already generated at the export.

In Linux, you right-click in the folder where your exported files are, and select “open in command prompt” or something similar (depends a bit on the version).

Then you enter the command from the text file (you don’t need nano for that, just open it in any reader) and confirm with enter. If snaphu was installed correctly, a process for phase unwrapping is started and the img file is generated. You then import it back into snap using Radar > Interferometric > Unwrapping > Import using the instructions given here: Problem in Snaphu Import section

Please note that since snaphu v1.4.2 you don’t need ubuntu any longer and can run snaphu from Windows as well without any installation:

1 Like

Hi There, I’m having the same issue with snaphu, when running it from the terminal I get the following message:
“Can’t open file cohIW2_VV_07Mar2016_31Mar2016.snaphu.img
I just install SNAP 8. I had an issue before with with the S-1 TOPS Coregistration that I solved installing the libgfortran5. Not sure if this had anything to do. All the other process ran fine. Just the unwrapping is not working. Any clue what could be the cause?
Cristian O.

can you please show a screenshot of the files in the folder and share your config file?

Hello Andreas,
Thanks for the quick answer. Bellow a screenshot of my folder, and configuration file attached

snaphu.conf (1.7 KB)

Cristian O.

somehow the coherence has not been exported with the product. Did you disable it during the interferogram formation?

I’m checking the multilook operator, and I’m able to see the coherence there, same information I see in the product explorer

I have deleted everything and running it again, but the issue remains

No idea why is just exporting the phase and not the coherence…

Because you are using a graph, we cannot exactly tell at which step the coherence is lost.
You could add an “Export” for every operator to see how the intermediate products look like and if they still contian coherence.

Dear Andreas,
Thanks a lot, there was some issue when exporting from the goldsteing filtering, I ran just the snaphu export operator I finally can see the coherence file in there, so far snaphu is running ok, I’ll keep my finger crossed :slight_smile:
Cristian O.

Now I’m having the following issue when using the snaphu import operator:

Any advices?

is there a chance to see the full error message?

This is the full text

These are the files
I’m importing the .hdr file. This is the popup message when importing it

and this