Cannot open Level-1C product by Laptop

Dear friends,

What are the requirements for system configuration of SNAP?
I installed it in my laptop (Intel Core i7, Window 7 - 64 bit operating system, RAM 4 GB) but I cannot open S2A - L1C product which is successfully opened by desktop in my office.
When I open the product with my laptop, after I select the reader (Sentinel-2 MSI L1C - Resampled at 10m resolution - WGS84 / UTM zone 48N), a pop-up is launched informing product is being read. But after that, nothing appears in my product explorer tree.
Is there any specific supportive software that I need to install in my laptop to deal with this problem?

Thank you for reading this!
Khoa

Hi,
sorry for letting you wait for so long.
I fear that 4GB of RAM is a little to low for working with S2 data in 10m resolution.
Try the 60m resolution or create a subset when opening the S2 data.
You have the option to create a subset while opening the data if you choose from the menu
File / Import / Optical Sensors / Sentinel-2 / S2 MSI L1C.

1 Like

Hi Marco,

after working at lot with MERIS data and BEAM VISAT I just installed SNAP to look how it works. All my MERIS *.N1 data and my processed .dim data can be opened and visualized. But opening SENTINEL-2A products is not possible. When clicking to the S2A_OPER_MTD_SAFL1C_PDMC_20160417T02090.xml file in the S2A directory, reading of the product starts. I see in a little info box “Please waait while data product is being read …”. This looks promising. But after a short time, the ínfo box disappears and nothing is seen on the screen except a liitle red dot in the lower right corner. Here I see the following error meaassge:
Unexpected Exception
java.lang.StackOverflowError
at com.sun.jna.Native.invokeInt(Native Method)
at com.sun.jna.Function.invoke(Function.java:390)
at com.sun.jna.Function.invoke(Function.java:323)
at com.sun.jna.Library$Handler.invoke(Library.java:236)
at com.sun.proxy.$Proxy43.GetShortPathNameA(Unknown Source)
at org.esa.s2tbx.dataio.Utils.GetShortPathName(Utils.java:45)
at org.esa.s2tbx.dataio.Utils.GetIterativeShortPathName(Utils.java:54)
at org.esa.s2tbx.dataio.Utils.GetIterativeShortPathName(Utils.java:82)
at org.esa.s2tbx.dataio.Utils.GetIterativeShortPathName(Utils.java:82)
at org.esa.s2tbx.dataio.Utils.GetIterativeShortPathName(Utils.java:82)

I tried opening my product with all options (native resolution, 20m resolution, 60m resolution) but in any case it failed. Also your tipp to select a subset was not successful.

For your information:
My zipped S2A test products are downloaded from the ESA Scientific Hub, from USGS and from Amazon Web Service. Uncompressing was done using 7Zip.

I am working with a Windows 7 Professional system with 8GB RAM. First I installed SNAP 32 bit. But unfortunately opening failed. Second I tested SNAP 64 bit, It also failed.

What should be done to open S2A products?
I hope you have some helpful ideas to overcome my problems.

Thanks in advance for your reply and all the best,
Kurt.

Hello Kurt,

Probably you have been bitten by the path length problem.
On Windows it is a problem to have a path length of more than ~250 characters.
So I think your problem is solved if you copy your data to e.g. c:\S2
At least make the path as short as possible.

Than it should work.

Hello Marco,

many thanks for your advice. Now it works.
Kurt.