Cannot open SNAP 8.0 in Ubuntu 20.04

Good morning,
I have tried everything(?) and I cannot get SNAP8.0 to open in Ubuntu 20.04. Even tried ALACARTE to add STEP8.0 to the ladder but no success getting it to run via that route. Any suggestions will be appreciated.
I have copied the Snap desktop.desktop to the Desktop and that still doesn’t work.


Same problem here, I had to go back to version 7.0

I installed SNAP on Ubuntu 20.04 yesterday and it works for me in the end: What I did

Download the all toolboxes version from here:

cd Downloads
#do not run the next line as root
#Unpacking JRE ...
#Starting Installer ...
#Gtk-Message: 10:43:32.631: Failed to load module "canberra-gtk-module"
#gui installer fires up
#used default settings, did not connect to python during installation
  • hit Win-falg key and serached for SNAP klick on app
  • SNAP fires up shows some dialog about versions but then the GUI fails and SNAP closed itself
  • again (Win-flag search and open SNAP) because stubborn, wait until the Plugin installer window allows clicking “finish” button
  • click “finish”, SNAP works.

Did some standard S2 processing without any troubles.

here apt_installed_Ubuntu20-04_running_SNAP.txt (140.3 KB) is my output from

apt list --installed

If you are interested in more configs of my machine, let me know what you want to know, maybe that helps to find what is going on.

One thing to add, after each reboot the first try to run SNAP fails, from the second try on it works for me.

1 Like

Afternoon jsa,
Tried what thho said but didn’t understand anything after the install part (that is where I am at and surrendering) could you email me a copy of V7. to me Thanks Neville

Edit by @ABraun I removed the mail address, please use private messages for this.

Please take a look here:


One comment that maybe can be useful (maybe not), be careful with SNAP install path in Ubuntu. Canonical universal package manager Snap it use the path /home/<user>/snap/ to install and manage it software, and this is the same default path of the SNAP installer (however during installation you can select any other path without problem, I use /home/<user>/esa-snap).