Cannot read operator template error in Sen2cor

May anyone help me to solve the following issues? while trying to use the Sen2Core V2.5.5, the following error pops-up.

Is the template indicated location valid?

yes, it is but I couldn’t find the file “Sen2cor-template.vm” in the specified folder

It means the template couldn’t be copied there when installing Sen2Cor, check the writing rights for the .snap directory.

sorry, the file is also available there. I don’t know why it doesn’t read

Ok, what’s the status of this plugin in Tools → Manage External Tools?

here is the screenshot

Ok, then what you need to do is:

  • select the plugin and click on the Edit button (pencil icon)
  • from the Bundled binaries tab (the last one on the left) click the button Download and Install Now (from the Windows OS tab on the right)

After installation, it should correctly update the location and the status should be green:


Thanks a lot the error is now solved, but when I run nothing happens

I mean there is no product neither displayed or stored anywhere in my PC

That is normal, the Run button from here only opens the operator UI

You can click on the 3 dots button (on the right of Source product) in order to select an input product from your PC.

sore for asking naive question, but where does the processed product stored?

it seems some thing still missing. I received the following when I run it.

Also doesn’t allow me to select the input product. The “I/O parameters” button disappeared

I don’t see the “I/O Parameters” tab in your screenshot … you have only the “Processing Parameters” tab.

Try to re-open the Sen2Cor UI and explain why you cannot set an input product.

What happens when you click on this 3 dots button?


I am facing the same issues. There is no option of I/O parameters even after i download the bundles.

How can we reproduce this strange behavior? Can you please provide more details? E.g OS, SNAP version, Sen2Cor version, and the steps you are doing.
By the way, do you have the same issue using the latest Sen2Cor 2.11 version?
Thank you in advance.