Can't import vector data

I have SNAP 4, with all the toolboxes, plugins etc. I can’t seem to import vector data - all the options in the ‘import vector data’ tab are greyed out. If I try to drag and drop a shapefile I am told there is ‘No appropriate product reader found’. What am I doing wrong?

Do you already have data in your project?
It is possible to integrate the vector data within an existing dataset. Try opening a raster from your study area and then the option “import vector data” should be available.

1 Like

Thanks - I was trying to open the vector data with a NetCFD opened - this didn’t work, but when I used a Tiff file it did. Cheers

I have the same problem. I´ve opended S2-MSI L1C data and a raster of one band. And all the options in the ‘import vector data’ tab are greyed out. What can I do?

This also happened to me once in a while. It should work if you select (click on) the name of the dataset in the product explorer.
_[1] S2A_OPER_MTD…


Ok, thanks. It worked… I thought I had any problem with the installation.

Is it possible to convert classified image to vector using SNAP??

No, this is not possible at the moment. But we have it on the development plan.

1 Like

Hello everyone,

I’m also getting “Failed to import vector data” error when I try to import multipolygon layer. Is there a limit of polygons which can be imported in SNAP? Because my shapefile contains quite large amount of polys ~5K polys.
Below is the screenshot from the error:

Thanks in advance!

The message java.lang.Null… most likely it refers to the memory issue, but would you please to share the sh.f, if that possible, Also you could check up the plenty of similar java.lang.NullPointException error within the search function in the up right corner of the STEP FORUM,

As @falahfakhrisaid, if you can it would help us to find the cause of the exception if you can provide the shapefile. A specific limitation of number of polygons is not implemented. If you don’t want to share it publicly you can send it as a private message to me.
What also might be helpful is if you share the log file. You can find it by selecting from the menu Help / Show Log Directory. Make sure to reproduce the error first and then attach the messages.log file.

Thanks for the hints @falahfakhri and @marpet. I think it is really related to the number of polygons within the shapefile. I tried importing a shp with 1000 polys and didn’t work but when the number drops under 500, the import is successful.

I am struggling with the same issue:

My .tif file is selected in the Product Explorer and when I try to import an ESRI Shapefile everything is greyed out…

Are you sure you selected the product and not the band?

Is your tif file geo-referenced? Is it shown on the world map or are geo-location values displayed in the Pixel Info view?

I am super sure, it is geo-referenced actually.

Then either it is not geo-referenced, or SNAP can’t handle the information provided in the tiff file.
What happens if you open it in e.g. QGIS?

in QGIS it shows all right. Maybe it is due to not updated SNAP v8?

Check the GDAL versions used bu SNAP and QGIS. Newer GDAL versions added support (via the PROJ library) for additional projections. Check GeoTIFF projections has a links to addtional details.