Can't open GRANULE in SNAP

Hi there,

I am encountering an issue opening a GRANULE .xml file. Whenever I try to open it it returns the error “Invalid input”.
However this happens only on the granule .xml because I can open the whole product with the main .xml.

I have read about unzipping with 7-zip but this doesn’t appear to solve anything.
I need to work just with a granule because the whole scene is too large…

My product is:
and I’m using ESA SNAP 5.0 with all the updates on Windows.

I have also considered working with snappy to resample, make a subset but that returns some Java errors I guess related to my pc RAM (although I work on an i5 3.2ghz with 8gb ram).

Any solutions? Thanks

So it appears that it is the same problem as ever, and that is: the number of characters.
It windows, the archivers that I tried, WinRaR, 7-zip apparently when performing the extraction due to the long string of characters in the name product, some paths to the GRANULE folder are broken in the process and SNAP can’t read properly the .xml and its paths.

This is solved extracting with Total Commander.