Change in image when converted to geotiff and loaded in QGis

Hello I am having an issue.
I followed a tutorial on ocean color using CR2CC processor.
When I obtained the final product I saved by selecting only the chlorophyll and unc_chlorophyll
and not selecting any bands in metadata option.
However, When I uploaded the image in qgis I get a different image with a different colour palette.

I have attached both the photos.

Can anyone please provide some advice. It’s

very important.

Thank you

Yours Sincerely

QGIS simply opens the raster. Only SNAP is able to read the metadata and apply the predefined color scheme.

Please have a look here: Colurful fringes are not colorful in tif


Dear ABraun

Thank you for the reply. I will try to follow the steps
and get back to you if I face any issues. :slight_smile:


QGis probably tries to create some default RGB image from your data.

If you want colourised GeoTiff you can right-click in the image view and select “Export View as Image”. Choose Options “Full Scene” and “Full Resolution”. As file type select GeoTiff.

In this case, you will lose the geo-physical values, but preserve the colours.
Or you do the colour manipulation in QGIS as ABraun suggested.

1 Like

Thank you Marpet
I will try the suggestion provided by ABraun.


Hello Marpet and Abaum

So I followed what Abaum suggested.
Things went fine. But I have noticed that
I areas which I have masked by using the cloud_risk mask in SNAP
is showing also showing colour. Any idea on that.

P.S. I have removed the values of cloud_risk areas by entering && !Cloud_risk


Dear Marpet
I tried following your solution. But in that, I case I will have to ignore the error band
which is produced as unc_chl. Moreover, when I save the image and open it the land mask and cloud mask

. Any idea regarding this.?


Jpeg does not support transparency. The no-data is transparent in SNAP.
You can save it to png. This image format supports transparency. Or you add another layer on your scene which represents the no-data and colourise it.
The simplest way is to use the no-data overlay image.
From the layer managerimage, you can change the colour by using the layer editor image.

1 Like

Regarding your first try with the cloud_risk masking:
How have you masked the clouds? Have you edited the valid-pixel expression?

This is not applied to the data when writing to GeoTiff.
But you can create a new band with the band math. Just reference the chl_con band. During this step the mask is applied to the data.
And if you export this, this colud_risk pixel should be removed.

1 Like

Dear Marpet

Thank you for the advice. Yes now its working fine. As you have said, the sentinel 3 staff also suggested me the same. creating a new band and editing the valid pixel expression if (!Cloud_risk) then conc_chl else NaN, further unselecting the virtual option and replacing the NaN with a value (-1), since Qgis does not recognize NaN. Regarding the geotiff image, I found that relocating the image and overlaying on Google earth also works fine. I can further georef the image in Qgis to place the coordinates and update the scale. Thank you so much for the timely advice. :slight_smile: But I wanted to confirm if I overlay the image on google earth I will be ignoring the unc_chl band. Will that make any difference.?

Ignoring the unc_chl band for google earth is ok. It depends on what you want to show. The only difference is that the uncertainty is not visible. But that’s okay. It really depends on what you are doing.

1 Like

Dear Marpet
I am actually trying to show the chlorophyll a or ocean productivity data from the Andaman coast of Thailand. :slight_smile:

Dear @marpet

I would just like to add that as from my experience. it is better to do the reprojection before the CR2CC processing. Because I noticed that the values shift when a CR2CC processed image is reprojected. :slight_smile:

Thank you