Checking for updates failed


All are corrects,

It responses very well and quickly.

This is the case I have now, without to apply the details are explained by you, Does that mean everything in proper mode now?

Yes, It means the updates worked properly and your application is up to date.

Tremendous thanks to you Oana, for your kindly help.

You’re welcome!
In the end, it seems that the only working solution was “try again later” :slight_smile:

I totally agree with you, but it is good to know for future cases.

I am trying to perform S1 back geocoding on SLC (My stack overview is

using 7 S1 SLC images and SRTM 1sec HGT DEM. After back geocoding master and 3 slave images are ok but 2 of the slave images are blank. I am using SNAP8.0.0 and trying to update to 8.0.3 in order to solve the problem but after 20% download of plugins following error occurs:
“Not all of the plugins have been successfully downloaded. The server may be unavailable at the moment. Try again later.”
I have followed the steps mentioned by @oana_hogoiu but nothing works for me.
Can somebody please tell me why is it happening? and how to get rid of it? Thanks in advance.

Maybe the plugins and updates are two different things here, because none of the optional plugins is involved in the BackGeocoding. Still, the core update to 8.0.3 should complete, I agree.
You can go to Tools > Plugins > Update and see which updates are suggested and then only update the essential ones (SNAP Engine Kit Module and Sentinel-1 Toolbox Kit Module). Please check if at least these can be updated.

This usually happens due to poor network or high traffic on server. Currently there is no high traffic on the server. When did you received this message? After which time interval did you retried?
Also, as @ABraun already suggested, if there are many updates to be installed, you can try to choose the ones that are mandatory for you now.

I tried it at 12.00 (Pakistan’s Local Time). I tried it at 06.00am too. I have now tried to install updates suggested by @ABraun but error occurs again (screenshot is attached)

has it ever worked to install updates or does this happen every time?
If so, you might disable your firewall during the update process to see if it blocks SNAP from accessing online resources. Alternatively, you can constantly open port 443 in your firewall settings. How to Open a Port on Windows Firewall
Windows and Mac: How to open ports in your firewall

“Your cache may be out of date. Please click Check for Updates to refresh contents.”

I have disabled firewall, opened port 443 and cleared cache still same error is occurring. What else can be done?

Clearing browser cache has no relation.
This is the way to clear/refresh the updates cache:

Accessing STEP website ( works for you? (in a browser)

Also, what version of SNAP are you using? You can see this in Help -> About SNAP, on the bottom part.
Were you able in the past to install updates ? (for 8.0.1, 8.0.2)

Even refreshing cache doesn’t works in my case.
Yes STEP website is accessible from my browser and I am using SNAP 8.0.0

I am installing updates for first time. Do I need to do some proxy configuration? When error occurred I clicked on proxy configuration but nothing opened
Snap version available on step website is 8.0.0 or 8.0.3? I am thinking of downloading it from there and installing it.

SNAP (installer) version available on STEP server is 8.0.0. Only with the updates you can obtain 8.0.3.
Are you behind a proxy? (only in this case a proxy configuration is needed)

Hello! Can I manually download and install the plugins? Because the URLs on which snap gives networking problem are accessible from my browser and I can easily download plugins from there. But I don’t know how to install them. Is it possible to install them manually?

When I try to open the link highlighted in

image following error message is displayed on
Does it have something to do with my problem of being unable to update snap?
Secondly when I click on hyperlink in plugins dialog box of snap application it opens with internet explorer which doesn’t supports this URL this may be the reason behind networking problem error. Although my default browser is Google Chrome for http and https protocols . I don’t know why it opens with internet explorer and how to change it to chrome

as indicated in a previous post, the update center base url is at

Can you access that?

Don’t know why there is that strange url in the package (@marpet can you have a look) but you should check with your browser if you can access, list, etc that page.

This URL is wrongly created by our build system.
It is almost already fixed. [SNAP-1428] The homepage URL is wrongly generated - JIRA (
And it has also been reported to Netbeans.

How the nbm files can be downloaded I have described here:

1 Like