Connection refused when downloading DEM

I am using SNAP GPT to process backscatter from SLC. The process is run on multiple machines in parallel (each machine is processing a different SLC scene).

Since today morning all of the processes fail with error:

INFO: http retrieving
SEVERE: Failed to download remote file. Connection refused (Connection refused)

All of the machines are connecting to the Internet via external IP address

When I tried to run command:


Then I also get a “connection refused” error.

On the other hand, if I run the same process on a different machine with another external IP, then the DEM download is successful without any error.

Is it possible that my IP was blocked by the server due to too many requests? What do I need to do to unblock the IP?

Yes, your IP is currently banned.
There are some rules and limitations enforced:

Hello, Thank you for the reply. I have stopped the processes and will retry after 24 hours on a smaller number of machines and also add some delay between the SNAP GPT calls to reduce the number of simultaneous open connections.
Do you have information, what is the maximum number of allowed open connections at a time from a single IP address?

The maximum number of allowed connections at a time from a singe IP address is 10.

If you have a large number of machines, you should actually consider running a local mirror! We are only keeping a copy of these files in STEP for convenience and last resort. People should use the official distribution channels as much as possible and people doing cluster parallel runs should consider running their own local mirror (specially because of network and security considerations that most of the times apply).


Thank you for the suggestion. Is there any tutorial available, how to (1) set up a local mirror and (2) how to configure SNAP GPT to use my local mirror instead of the default STEP server?
The processes using Internet resources from STEP are Apply-Orbit-File and Terrain-Correction. Apply-Orbit-File downloads some AUX files and Terrain-Correction downloads srtm ZIP files. Any suggestion, what the structure and naming of the orbit files and srtm ZIP files is needed for the local mirror to work, would help!


so I seem to run into a similar issue. I must have been blocked as I was downloading my SRTM s upfront (from the step server of course) to create a mirror myself. Now I am using Copernicus DEM, after having figured out that they reside on Amazon and are not limited.

However, while I solved the issue with DEMs, during co-registration of 2 bursts I get a connection refused error. If I read the error right, it checks for a new Snap version during co-registration? See attached error log.
20220204_A43_IW2_7635_coreg.err_log (3 KB)

Any suggestion how to run parallel processing on a big machine without running into this issue? Setting up a cluster is not an option for me, and neither sequential processing is, as it would simply take too long