Copernicus inexplicable CSCDA registration problem


I would like to download some ENVISAT ASAR data through the EOLI-SA application for scientific purposes, and for this reason I had to create a CSCDA account. Although I have registered and I have checked more than once that my password is valid, I still cannot log in as a Copernicus registered user - neither in the CSCDA System, nor in the EOLI-SA application.

I have followed all instructions, I have clicked on the link, that was sent to me via e-mail, received a confirmation of my registration, but when I tried to log in, I kept receiving the error message that I “misspelled” the username, or that I “have not registered yet”. That was the case with the CSCDA, as well as with the EOLI-SA application. I cannot understand why, since I tried to log in only a few seconds after I received the confirmation of my registration.

Can you please help me through this? It is of utmost importance that I get and process these data. Thank you so much in advance.

You should contact the ESA help desk here