Coregistering with TerraSAR-X

Hello,I am a graduate student and my name is tangyin.A few days ago,my tutor give me TerraSAR-X data,he wish me can use the SNAP software platform for TerraSAR-X data for processing.However,for SNAP,I am not familiar with the process of its operation.When I do coregistering,the software show that the product have no geo-coding.
I hope your could give me some suggestions,thank you!

Coregistration adjusts smaller shifts between images so you can stack them even if they don’t have a map projection yet.

The error about the geocoding shouldn’t arise however. How did you open the data?

Thank your reply.My tutor sent me data in two formats, one of the data format is 20091214.slc, another data format is 20091214.slc.par. When I use the software can only open the latter format data, and the image There is no coordinate. I think it is not necessary to modify the data format?

this is not the original image format so I suggest you open it with File > Import > SAR formats > Gamma.
The par file contains the metadata usually colums, rows, coordinate origins ect. This should be interpreted correctly when opening ins SNAP.

However, if you only have one raster there is nothing to coregister.

Thanks your suggestion,I open it with File > Import > SAR formats > Gamma.I have just tried your method, but still can not open it correctly.In addition, the world view does not show where the image is located.The open image still does not have the corresponding coordinates.

please ask your tutor if he has the original data as well.

If the data does not contain spatial information in the Gamma format you can not do much.

OK,I am very grateful for your help.

Hello, I have a few questions to ask you. I would like to use the TerraSAR data to do the coregistration, I open TSX-1.SAR.L1B> TSX1_SAR__SSC ______ SM_S_SRA ·> ANNOTATION, AUXRASTER, IMAGEDATA, PREVIEW and SUPPORT, AUXRASTER file with these formats CAL-QL-MRES-HH. Tif, STD-MRES-HH.tif, stdcalcomposite-MRES.tif. Then I opened two different time data format CAL-QL-MRES-HH.tif, when I chose radar-coregistration-coregistration, SNAP software appeared "Error: [NodeId: CreateStack] Orbit offset method is not support For this product: Ellipsoid.ell2xyz: input values for phi / lambda have to be in radiansl ". When I open File> Import> SAR formats> Gamma. There is no data format that can be opened in the file. Is this an open way wrong?

If this is an original TSX product, open the TSX… xml file at the root folder. It should be file like

Thanks,Firstly,I creating a subset which I are interested.I do from Interrerometry Turorial , the steps is coregistering>interferometric>topographic phase removal>phase filtering>phase unwrapping>geocode the product.When I do phase unwrapping,according to Interferometric>Unwarpping>Snaphu Export,but there not appear similar to UnwPhase-ifg-srd-07Aug2014-31Aug2014.snaphu.hdr in file.Next,I cannot do Snaphu Inport and geocode the product.I do not know where is problems in processing?

the SNAPHU export creates the header file UnwPhase-ifg-srd-07Aug2014-31Aug2014.snaphu.hdr but not the corresponding image. This has to be created outside SNAP with snaphu:

Please also see here:

If you successfully processed the unwrapped phase, you can import it into SNAP again.

OK,I have download “Installation_SNAPHU_English_ABraun.pdf"and browse.The requirements is cygwin and snaphu.My windows is 64 bit version.When I installation cygwin,
g.Chose a server in your proximity,I chose “”,next; for „make“> under Devel > select make: The GNU version of the ‚make‘ utility
i. search for „gcc-core“> under Devel > select gcc-core: GNU compiler Collection > Next
To be honest,I can not understand step " for „make“> under Devel > select make: The GNU version of the ‚make‘ utility"and step"i. search for „gcc-core“> under Devel > select gcc-core: GNU compiler Collection > Next”.As for step i ,I input “make” in the box next to" Search" and then proceed directly to the next step,Do I need to click to"clear"?I want to know that is right?

you use the search box to find the packages to be installed: make and gcc-core. You chose them for installation by selecting them and clicking next. They are installed in the following.

OK,when I install SNAPHU,
c. Move to your user directory and create sub folders (man/man1) by typing
cd /usr/local/
mkdir man man/man1
d Move to the unzipped folder by typing
cd /cygdrive/c/temp/snaphu-v1.4.2/src
Is not when I type cd / usr / local /
Mkdir man man / man1, and then directly in the next line type cd /cygdrive/c/temp/snaphu-v1.4.2/src?
e. Prepare the compiler by typing
make install
when I typing make install,the windows show that No command found.

Then you didn’t install the make utilities properly. Please have a lool at the cygwin manual and run setup.exe again in order to install make and gcc-core.

I have run setup.exe again and again.At last,
a. The interferogram exported from SNAP is located in C:\Temp\export
If snaphu.exe is not in your system’s PATH variable: Copy it in there as well.
b. Open the windows command terminal by holding the Shift key and right-clicking > Open
Command Window Here
c. Type snaphu and hit Enter. The help menu should be displayed.
When I do step c, shows that Can not start this program because the computer is missing cygwin1.dll···.
but I did not have problems before proceeding.I’m a little confused。

please install cygwin correctly first, including the packages make and gcc-core

I can’t support you much on that besides the PDF manual, sorry.

Thanks,I will still try again. I first found Cygwin1.dll under C \ cygwin64 \ bin and copied it to the snaphu-v1.4.2 \ bin file. But when I run snaphu.exe , it immediately quit.

Instead of moving the file, you should add its original folder to the system’s path variable

2.cygwin,I try again from it.I have add its original folder to the system’s path variable yesterday,but failed.So I moving Cygwin1.dll to snaphu-v1.4.2 \ bin file.