Coregistration issues regarding accuracy (S1 TOPS)


I’m new to interferometry and I try to create my first interferogram. I have coregistered two S1 images with S1 TOPS Coregistration and created an RGB image of the result - master image for R and G and slave image for B. I have read that the RGB image should not be dominated by one of the images (e.g. too yellow or too blue). But my image is almost completely yellow (image below) and I don’t understand why.

Both are descending and VV. The perpendicular baseline is 106 and the temporal baseline is 6 days. The incidence angle varies between 30 and 48. The area is very hilly with low vegetation and unfortunately I can’t say anything about the weather conditions.

I have found a few tutorials and I can’t see why the coregistration didn’t work. I appreciate any help and advice!

Are you sure you have two different scenes in the RGB? The water-surface at least should show some colours, while your image is monochromatic yellow.

there is a large proportion of water, did you exclude it from the Coregistration?

How do I exclude the water from the Coregistration? I have the option ‘Mask out areas with no elevation’ activated, but I think that’s not what you mean, right?

Good question. I assumed there was a checkbox for this in the coregistration but there is none.
Intuitively, I would increase the number of GCPs but this is also not possible in the Back Geocoding.
Not the most educated advise, but worth a try. Have you tried running it again?

Die you use a graph or did you process each step manually? The latter could also help ro check where the second image gets lost.

I did every step individually:

(1) S-1 TOPS Split


(2) S-1 Back Geocoding
With SRTM, bilinear interpolation and masked out areas with no elevation (default settings)
Master image:

Slave image:

(3) RGB Image
R = master, G = master, B = slave

With ‘S-1 Back Geocoding’ I cannot change the number of GCPs. I tried to use ‘Coregistration’ but then I got the Error that I should use S1 TOPS Coregistration instead.
Also, I wonder why the sea is cut out in the slave image.

Hi again,

I’m still trying to figure out the problem. A coregistration with the ESD technique was also unsuccessful. However, I could hardly find any information about the different setting options. Maybe someone knows a manual about ESD with SNAP?
Regarding the coregistration problem, is it possible that the ratio of water and land is causing the issue? Is it perhaps not possible to coregister such small islands? The picture shows the whole subswath. I read in a paper that the incoherent cross-correlation technique (ICC) could be useful for scenes with islands. But again, it was difficult to find more information about this technique.

Does anyone have any ideas?

According to the screenshots, the secondary image is not really empty, but just darker, is this possible? Because there are patterns indicating different pixel values in the RGB composite, they are just rather subtle.
Could it be that the secondary image is VH while the primary is VV?

Yes, you’re right, the secondary image is not really empty. It is just darker.
Both images are VH. I also processed the coregistration with VV, but the result was the same…

I still think that maybe the land area is too small for coregistration. What do you think about this?