CoRegistration of cropped Cosmo-SkyMed data does not work


I have some Cosmo-Skymed data (SCS-Himage) that I cropped. In the next step I wanted to stack and coregister all data. Yet, trying to apply the InSAR optimized Co-Registration results in a freeze. I do not get any warning or failure message, it just freezes. Has someone experienced similar problems? What can be done to co-register the data?



  • Toolbox version and operating system: SNAP 2.0.3 / Windows 7
  • RAM: 8GB
  • satellite products: CSKS2_SCS_B_HI_19_HH_RA_FF_20151216033810_20151216033817.h5 (plus 2 more of the same kind but different date)
  • exact processing steps: 1. Create subsets of all scenes with identical corner coordinates within SNAP. 2. Apply InSAR optimized CoRegistration in SNAP

Presumably the RAM 8 GB is not enough, and my suggestion to be sure that this is the RAM issue try to process only two images, and let see the result, the other issue might be the memory storage. please check out both.

Dear falahfakhri,

thank you for the quick answer. I did tried only two scenes at a time, so this assumptions can be ruled out. The memory storage, if you refer to the SSD memory, is 19GB., So from that side should neither result any problem. Or did I misunderstood you?

All the best

I didn’t work with this data before, but let me ask you, is this the level 1B DGM, SAR standard products?
and if yes, so are you sure that InSAR optimized corregistered is the appropriate method of this kind of data?

No, it is a level 1A product (Single-look Complex Slant -SCS), for which the handbook states that it consist of SAR focused data internally radiometric calibrated, in zero-doppler slant range-azimuth geometric projection, left at natural geometric spacing with associated ancillary data. So, I think it is suitable for InSAR optimized CoRegistering, do you think differently?

Please check out this

this is the link “

1 Like

Yep, that is the one I was referring to earlier. I use Level 1A SCS data, also given in the file name CSKS2_SCS_B_HI_19_HH_RA_FF_20151216033810_20151216033817.h5

Did someone else have similar experiences and found a workaround or a solution?

Have you tried creating one subset for the master product and then coregistering with all slaves (without subsetting)? Also, check that you haven’t maxed out your disk storage or memory.