Coregistration with Back Geocoding does not work

Hello everyone,

I want to create a DEM from S1 data. But alleady the coregistration of the two images does not work. The output from Back Geocoding are six immages, containing only zeroes. The split and the AplyOrbit operators word. Could anybody pleas check if the Graph is running at his computer? I tried it alleady with graph processing and manually. Both does not work.
This is the Graph I use:

Graph.xml (5.0 KB)

It is the same Problem as described here, but I have more than 66 GB memory left.

Phase problem (single purple color) in interferometric processing chain

Is there any solution to this Problem

any specific reason why you don’t start with the TOPS coregistration? It includes downloading of the orbit files, selection of polarizations and splitting and coregisters the remaining data.

Because TOPS coregistration is not supportet in graph builder (see screenshot). I also tried TOPS coregistration manually. Some days ago it worked well, but now it doesn’t. The graph I uploaded is nothing else then a reconstruction of TOPS coregistration.

that’s true. I don’t have an explanation to be honest.
Did you try if it at least works with the module?

With which module? I can’t run the Back-Geocoding function. It doesn’t work on my private computer and also not on the university computer. Have you tried to run the Graph?

I see, it is missing in the graph builder

I didn’t have time to download the images and run the graph yet.

you do not have to donload exact these images. You can use others too.

I can also open S-1 TOPS Coregistration outside the grap builder, as in your screenshot, but not inside the graph builder

And does it finish?

It does finish (product is saved and opend), but the output only contains zeros. When I open it, i see only a grey image. It’s the same problem as in the link with the purple interferogram.

It happening me too. I tried 5 pair image. Before yestarday, it was working. After update some plugin, it doesn’t work.
Im really shoked on this problem. All coregistration’s slave image phase, density bands are empty. Phases are purple.

There is any bugs?.

Therefore, i tested snap 5,6 version to install, reinstall mode so on

My Snap doesnt work from stage S-1 TOPS Coregistration.
Is here, anyone with problem like as me?
How i can solve it. This data was working normally in previous.
Please have a look at this picture. Slave image is emtpy, all in purple on phase band.

if the backgeocoding is empty, the coregistration failed. There can be many reasons for that. Are you sure that you have selected the correct number of bursts? Sometimes SLCs are shifted a couple of bursts in azimuth direction. For example here:

Yes. sure. I have a checked ten times :-p

Today I updated SNAP and now Back Geocoding is working again.

Hi, Please tell where from to do so and how. I am new to all this. Thanks for the help !!!
What I know is previous versions are available at : and the latest, 6.0.0 at : . Please tell which version should I use so as to resolve this issue. One more thing, does SNAP always come bundled with Sentinel-1 Toolbox ? I want SNAP with S-1 Toolbox, which I believe this link serves the need. Any other installation or configuration do I need to do. Thanks alot.


@ga96dag I tried version 5.0.0, now both Master and Slave Intensity files are zero.(between 0 and epsilon). This is further mess. 6.0.0 at least gave non-zero Master . Can everyone be specific while talking of versions ? I could not conclude much from updated the version ?

I’m not sure if the update solved the problem, or the fact that i wasn’t working with snap for a few days. I know this sounds stupid, but at the first day I had problems, there were zeros in the slave image, the second day in both, after a few days again only in the slave image and after a week (with update to 6.0) the problem was solved. So the problem became smaller also without the update. In the lower right corner of the snap window you can check if updates are avaible. When you install snap, you can sellect the toolboxes. It’s sad that snap has this problem and dos not even give an error message.