Corrupt image when trying to upload Envisat data to SNAP

Hey there,

I have been trying to look at some L1 Envisat data from October 2003 using SNAP. I have been able to upload the files (by either dragging and dropping the file or using the import feature), but every time I try to load one of the bands, the created image is completely warped (as seen in the screenshot below). This is true for any band that I try to load.

Has anyone had this issue before? Let me know if there is any way I can fix this.

Displaying i and q doesn’t make much sense because they are complementary parts of a complex signal. You can convert them into Intensity by radiometric calibration (or directly with Raster > Data Conversion > Complex i and q to Intensity

1 Like

Thanks for the reply. Unfortunately, no luck so far.
After doing a radiometric correction on some of the images (Files 3 & 4 are the corrected images), I still have what looks like a corrupted image.

I also tried the direct conversion using the “Complex I and q” tool you mentioned and got similar results.
I’m really not sure what I’m doing wrong. It looks like the images are much narrower and taller than they are supposed to be as well. Not sure if that’s helpful to mention.

After looking at the image closer, the image does indeed seem to be showing some terrain (for one of the files at least). But this image has been stretched vertically for some reason, any idea how to fix that?

This iscaused by the imaging angle of the system. The steeper the incidence angle the stronger the distortion. This is completely normal for SAR images.

image source

Apply Multi Looking to get ground geometries.

1 Like

Wow, that worked for one of the images! That’s amazing thank you so much!

I’ve had less luck with the second image I’m working with. The ASA image is still stretched after using the Multilooking tool. I did notice that several blank bars are spliced in between the image, maybe this is causing an issue? I’ve attached screenshots:

I’ve also noticed the worldview overlay looks very off, not really sure if this is also part of the same issue.

This has been incredibly helpful so far thank you very much.

could it be that the second one was not downloaded correctly? Looks rather like a file error.

1 Like