Corupt in result oil spill detection

hai, I’ve been process oil spill detection but the result isn’t covers all area like image below… anyone know why this happen ? I’ve process with another date before but the result is ok.

Did you check the threads under this post, and continue within one of therm if that possible, because it is the best option for everyone when searching similar issue under one post rather than multi-duplicates,

Yes, i’ve read the forum about oil spill detection, but not have any answer about my problem yet.
Why the result like crop automatically like that ?
I doing over and over again with different parameter and different date(except one date) but the result is same. Do you have solution ?

Continue under the closest one, in that case many people will take a look at your question.

Which one forum do you think closest with my problem ? I really stuck. Thanks before

What do you think to continue under these both, select one of them and continue,

Also, did you check up this video, to find out your steps,


I did read but i don’t find any answer related. My problem here is why is the result like stop and crop whereas the result of sigma_vv is good, but the result of oil spill is like that ?

And when i try in the different computers, this happen… what kind of buffer ?

What I meant in my previous post is to continue under one of the aforementioned topic, to make this Forum easy to follow and to reduce as much as possible the redundancy of similar topics, but anyhow,

Please also take a look at the following OIL SPILL MAPPING WITH SENTINEL-1

Check up each step in your processing, to find out the source of the error,

Hope this helps

I used the video training kit to process my data btw.
Thanks for trying…

Can you please help me mr. @ABraun ?
Thanks for your attention

because the algorithm masks out all land pixels based on SRTM3


There were some problems with SRTM3 lately, so you can try

  • remove the checkbox “Use SRTM3”
  • digitize a vector containing the land pixels and select “Use Vector as mask”

I Will try that way…
I already have shapefile for input, but i can’t import in snap as image below, what should i do ?

Select the product name instead of a band on the left and the option will be active.

Ohhh, omg yes, thanks for info.
But then i got this error, what is the meaning ???
what should i do with shp data before i import in snap ?

maybe something in the attribute table or the file/path name?

Okaayy, i give it a try to change shp’s name then it work… thanks…

So sir, i tried use vector as a mask and the result is same, automatically crop like that. But when i try with default value of background windows size and threshold it isn’t crop.
Where is the source of eror ? Is it background windows size or anything else? But i apply same value in another date, there ia no crop. So confuse.

I don’t have an idea to be honest - I nevers saw this error. Did you stick to the BEAM DIMAP format for all intermediate products?

I stick to BEAM-DIMAP sir, but one day i have tried use ENVI format, and the result is same.