Creating "New vector data container"


I need to do some diferent data containers for making clusters (for polarimetric supervised technique classification). I don´t know why the button of this option is always disabled…How can I fix it? It seems that no mattet what product I have open or what I´m doing…it´s always disabled…



Yes, I had the same problem. It turns out you need to select the product and then it becomes enabled.
This is unnecessary since even if you select a band it could figure out which product it came from. I’ll create an issue for this. Thanks.

Yes also,

I keep on trying and finally, selecting the product, or even the Vector Data Folder, the button turns on and you can do vector data containers or see them.

Im trying to make classes of sea, bare soil and building for post Supervised Wishart Classification. Now I´ve got the different vector containers with these classes, and I have done the training_cluster_centers.txt but it still, keep on making an error when the SNAP open the txt for doing Supervised Wishart Classification. I don´t know why, but I´ll keep trying. It is of a problem I comented two days ago at polarimetry issues. That time I did with only one vector container. Now I ve tried with those three. Keep on.

Thanks to you,


I’ve just tried the supervised classification training and it worked fine.
I used the master branch on Windows.
What OS are you using? Maybe it’s having difficulty with something in
path. Have you tried to another location where you know you have write
permissions to?


The OS…ummm I didn´t think about it. I´m using Windows 8.1. I tried so many times but nothing…! The path location…? I try now to change the path location and also on Windows 7 with another machine and see results… Keep on. Many many thanks Iveci!


I just tried with another OS (Windows 7) and changing also the location…but no way. It must be something that Im doing wrong, I don´t get it! Please, Iveci, could you make some screenshots for the main steps you are doing (and you success) for cheking if there is something I am failing…¿?

I agree with you that it seems, a problem of path location or a permission… As you can see at the another post of (Supervised Wishart Classification) the error keeps the same…I don´t understand why, because it´s at opening and starting.

Could you tell me if this txt is the regular format or contains of a training_cluster_centers.txt on the picture?. I just created three classes for trying the classificator. I think the txt file is correct no? It´s normal?

Im very interested on Sup. Wishart Class on my study research…! Thank you very much. Anyway I keep on trying to understand the error.


If it is useful… such on Windows 7 as on Windows 8.1 executing with master permission, the error is exactly the same:

Lines 417, 115, 499, 278… of the program code on java. It could be intersenting know whats on these lines, I just wonder myself if it is there the answer.



Is it possible to do a Supervised Classification with DualPOL-Sentinel-data in SNAP??

Yes you can do supervised classification.
To process dual pol Sentinel-1 SLC:

  1. First calibrate with complex output
  2. Deburst.
  3. Next you can run the Polarimetric Speckle Filter (This will automatically convert to a C2 matrix and filter it)
  4. Open a band, create new vector data container - give it the name of your label
  5. Draw a polygon over the training samples using this label
  6. Create a new vector data container for the next label, etc.
  7. Run Supervised Wishart Training using your labeled polygons and saving the training data to a file
  8. Run Supervised Wishart Classifier using your C2 data and the train file.


is it possible after doing a Unsupervised H-Alpha Dualpol Class to give each class a different colour AFTER doing the terrain correction? Because the Terrain Correction always chages the colours.

You should use nearest neighbour resampling with classes



I tried out the Supervised Classifcation, but when I am doing it I alway get an error. I did exactly your instructions.
What could be the problem?

Here is the Problem Report:

Tim, I can’t tell much from the error just that it occurs in the initialize and it shows the file as the error.

Also, probably unrelated but, you should calibrate with complex output first or at least before the multilook.

I have also been trying to apply the supervised Wishart classification on quad-pol RADARSAT-2 data and I get the same issue as shown below.

It seems that a number of users have been reporting this issue and this seems like a bug in the software. One could use PolSARpro although it is not a very user friendly tool and I would like to have this functionality performed with SNAP. Therefore I would like to know from the developers if this issue is being dealt with?

thanks a lot

have you solved the problem?if you did ,please share