Data reading/writing issue with 20 m resolution S2 bands

But first I would like to warmly thank all the developers of SNAP 2.0 for the superb job they have done that allow us to have a lot of fun with the Sentinel 2 data. The information in the boxes and the help files are also very informative too.

The problem I have is with visualisation of the 20 m resolution bands (only) of Sentinel 2. I tried with 2 different Sentinel 2 images along different orbits and the problem occurs in both images. At a low level zoom, the images displayed in the main window are fine, but at higher level the displayed images show large black vertical and horizontal “Scottish” stripes.

The transition between good and bad images is always around the zoom level 1:40. At 1:41 the image is still fine. At 1:37.5 the stripes appear.

Curiously, the problem looks like a display problem, as at low zoom level there are no stripes at all, and increasing the zoom generates enormous stripes. However, I exported the bands in GEoTIFF/Big TIFF as well as ENVI formats, and ENVI opens the images with the black stripes as black pixels at any zoom level. So it seems to be an issue within the data, or (perhaps more likely, I have never seen such artefacts on satellite image data) the way data are understood by SNAP and rewritten.

Below are two screenshots that illustrate the issue. Any hope to see it solved soon?

Left: zoom 1:49.9, bands RGB 12 11 8A; right:zoom 1:37.5, same bands.

I met the same problem using Sentinel-2 20m bands when navigation zoom level is lower than 1:40.
The problem occurs opening the S2A file in both “native resolution” and “resampled resolution”, and affects only bands at 20m resolution.
Export of the 20m bands in GTiff format generates a georeferenced raster image with the “Scottish” striping effect (containing value 0 as “no data”).

QuantumGIS does not create any artifact or “Scottish” striping effect when displaying the single 20m bands from “…/GRANULE/…/IMG_DATA/*.jp2” files in native JPEG2000 format, therefore the problem should not be related to the Sentinel-2 source data.



A new version of S2-Toolbox is available as an update.
Can you both please confirm whether you still experience this issue ?

Thanks in advance

Hi jmalik,

On my side, I fear that it has not changed…

Hi Daniel,

Confirmed here. I found a dataset with which I can reproduce the scottish effect.
I just filed a critical issue : and will work on it ASAP.

Hi Julien,

I installed the suggested update (Sentinel-2 toolbox kit module v 2.0.2) but I still face the problem.


Had the same result when exporting sentinel 2A to geotiff.

eventually I used the gdalwarp to export the data to geotiff which removed the scottish effect at the result.

This particular issue is now fixed with the latest 2.0.3 update of Sentinel-2 Toolbox.
Thank you all for your patience.

Yes it looks like. Many thanks jmalik and a happy New Year to you