Debursting - java.lang.NullPointerException

Hello there!

I just downloaded an inSAR image, and i want to process the data using the SNAP software. First things first…i have to deburst the data. When i go to Radar -> Sentinel - 1 TOPS ->S-1 TOPS Deburst…instead of debursting my data, it gives me this error: “java.lang.NullPointerException”.

Anyone has any ideeas?

P.S. Begginer level, still trying to learn.

Thank you!


what is your input product?


It’s an Interferometric Wide Swath Level 0 Product.

Level 0 is not supported in SNAP

SLC is Level-1 so it should work.

yeah, yeah…sorry…it’s level 1

now i tried these steps:

  1. Corregistration
  2. Interferogram Formation
  3. S-1 TOPS Deburst.
    The deburst is still in progress…i think it will work. First time i tried to deburst the data exactly how it was initially (from the archive / .zip)

Right, sorry.

After all…i managed to do the deburst…but now i got into another problem. I want to do a calibration of the data on the coregistered set of data. It says to me that i cannot do the calibration on it. Is there any other way to calibrate the values of intensity?

Calibration to Sigma0 loses complex information (i+q). If you want to calibrate for interferometric analysis you have to check “complex output”.