EAP phase correction not possible

Tue Oct 6 13:49:52 CEST 2015

Hi I do get an error message while forming an interferogramm:

Interferogram: Source products cannot be InSAR pair: one with EAP phase correction, one without.
org.esa.snap.framework.gpf.graph.GraphException: Interferogram: Source products cannot be InSAR pair: one with EAP phase correction, one without.

I tried to apply the eap phase correction to the first file, however this fails also.

The files I’m using are:

Hope you can help

It’s a bug and has been fixed. The fix should be in next release. Thank
you for pointing it out.

This error is related to the change of SAR-processor version in the S-1 Payload Data Ground Segment (PDGS) for one of the images and as Jun mentioned the fix is included in the next version, due soon.

Has this bug been fixed? I still got this error for one of the pairs in SNAP2beta8.

I am trying to create an interferogram from two SLC IW images (S1A_IW_SLC_1SDV_20141012T051732_20141012T051759_002792_003250_0D85 and S1A_IW_SLC_1SDV_20150703T051729_20150703T051756_006642_008DDA_8CF4) and I get the same error as @vhelm, namely:’ A problem occurred during the target product initialisation. Type: OperatorException. Message: Interferogram: Source products cannot be InSAR pairs: one is EAP phase corrected and the other is not. Apply EAP correction.’

I tried applying EAP phase correction to the 20141012 image but this does not work as well. I am using the latest SNAP toolbox (2.0 beta 8 (14.10.2015 20:13) ).

Any way to solve this?

Thank you

The time-difference between your images is very long - unless your test area is in a desert the coherence will probably be too low to be useful.

@mengdahl Thanks, but it does not explain why the EAP phase correction does not work. How do I get it to work?

I have tried your first data set (S1A_IW_SLC__1SSH_20150313T080159_20150313T080227_005010_00647C_F908.zip) with EAP phase correction and did not have any problem. What error message did you have?


I got the following error message in snap2stamps to use Stamps:

Any solution that I should apply?

I do not understand why in interferogram 1 (further away in time), it is created and in 2 that is closer than 1 not, the rest of the interferograms had no problem.

@mengdahl I have not had an answer in this last post,

maybe you have any idea?

This appears to be a snap2stamps issue, perhaps @mdelgado has an idea about what the problem is.

EAP correction is not included in the snap2stamps scripts.

My quick suggestion is not to consider data prior to 15 March 2015.
Another option is to apply EAP correction to older data.
My suggestion for newer SNAP versions is to include such correction automatically, as SNAP can detect which data need it.

However, I would have expected to see the same issue on the previous pair, 17 Feb, for which apparently SNAP cannot download the DEM.

1 Like