Ellipsoid correction GG

Hi I tried the
Ellipsoid correction GG and wanted to apply this also to Phase , Intensity and coherence Bands.
However the output does only include coherencer and intensity and not hte phase anymore, which prevents me to geocode the interferomtric phase.

I use the newest version of snap 2.0. In a former version I was able to geocode directly multilooked products but now I need to apply some of the terrain or ellipsoid corrections.

Any ideas


As you workaround you could turn the virtual phase-band into a real one and save it, which should enable you to geocode it too.


after multilooking using all bands I already have a real data file. Is
this still a virtuell band or how can I exactly is the work flow of your
proposed workaround?


Am 26.11.15 um 14:57 schrieb mengdahl:

Normally the I and Q bands are real and phase & intensity are virtual and therefore computed on the fly. Virtual bands are identified with a “v” in product view.


yes but how can I turn a virtual to a real band. I’m using the command
line and not the GUI and the phase was already output as a real data
file after multilooking?

Am 26.11.15 um 15:13 schrieb mengdahl:

In the GUI it’s “convert band” but I cannot find it in the operator-list…perhaps @lveci can help?

Yes, I confirm the EC GG is ignoring the phase bands. This is left over from when we used to have phase bands in any complex data product. I’ll fix this.

In any case, you are probably better off using the EC RD. This applies the same processing as the range doppler terrain correction but with the average scene height. It uses the orbits and should be more accurate and it will process the phase band if you have explicitly stated to use the band or if it is not virtual.

1 Like


many thanks. EC RD works fine. However, here I have one point. Why do I have to set both pixelspacings (degree and m). It would be more useful to only define one and the other should automatically be estimated.
Or even better having the option above and if none of the spacings is defined then the original spacing should be used. In the geocoding routines this option is present.

Thanks again

It should be that if you set one to 0 it would be calculated based on the other. This is how it works with the UI. It looks like a bug that it’s not happening from the operator directly from gpt. If they are both 0 then they do get calculated based on the source product. Thanks