Error: Cannot construct DataBuffer


#21

Hi everyone

I am having the same problem with “DataBuffer” and i’ve been reading the comments in the forum. So what is the solution to our problem in the end? My computer is using 4 GB RAM and i really need to use SNAP for S-1 SAR data.


#22

Have you already activated the file cache option?


#23

I do no not change, just i go to java web page and download de version in screen, however do you try with the other two things?


#24

see the images attached, i try in 2 pc’s with de same problem.


#25

Hi again

I have tried to do the same processing in a computer with 32 GB ram and it works perfectly.


#26

Is increasing the RAM the solution to this issue ?


#27

It worked immediately when i did it in a super computer with 32 GB RAM. My laptop and the desktop i am working with usually have 4GB RAM and i could never do anything with SNAP or S-1 toolbox. Now I did every process i wanted so i guess it is a RAM issue.


#28

Long graphs also consume more memory so breaking them into pieces may help.


#29

This problem is very frustrating. From what I’ve read I can see it is a RAM issue. My machine has 4GB of RAM. Damn!


#30

If you computer cannot handle processing full products and large graphs,

  1. Create subsets of smaller areas of interest
  2. Use smaller graphs or single operators
  3. In the tools options s1tbx dialog use the file cache for sentinel-1 reading
  4. In the tools options performance dialog use smaller tiles
  5. Close other applications using memory

Cannot set heapsize on ubuntu 16.04
#31

I was facing same problem during last weak, when i was try to calibrate SLC product of Sentinel-1A. Then I tried to create space from hard drive and that worked :). Actually I tried same process in my university P.C, and that went successful in first attempt. The output image was too heavy, having size of around 20 GB. Then, I created the space of more than 20 GB at my laptop also, which worked and I didn’t get error regarding data buffer construction.


#32

Does optimizing through the GUI impact performance & processing when implementing using snappy/GPF? I’m trying to do a processing graph that takes less than a minute in the GUI, but when I’ve coded it out using snappy and GPF, it fails with the DataBuffer error or JavaHeapSpace.


#33

Maybe it is necessary to edit the gpt.vmoptions file.
Uncomment the line with the xmx option and set it to e.g. -Xmx6G


#34

I found that using the GUI optimization did nothing for processing through python\snappy, and only improves performance when doing processing within the SNAP GUI.

To solve my issue, it came down to modifying the snappy.ini file as has previously been posted.


#35

<img src="/uploads/default/original/2X/7/7817b0bc672889f58258bac4234664f9e1f96e67.jpg" width=“690” height="3
Hello everyone!
I have a problem with Sentinel-1 in Steps 1 (Calibrate).


#36

I don’t have a solution but I fixed the inserted image for you.


#37

Hi. Thank you so much!


#38

Hello,

I had the same problem using gpt.exe - using GUI it worked fine. 8BG ram here, but my gpt proces is using only about 2,2GB

The solution which helped me:

Thanks a lot.


#39

Hello,

I had the same problem when working with IW SLC data, got error messages both with cannot construct databuffer and Java heap space. The solution was very simple - I moved the data from an external hard drive to the computer’s hard drive, and everything worked suddenly!

Very simple solution, but took me quite some time to find it. …


#40

Interesting, 1st time I’ve heard of this kind of behaviour. @marpet what do you think?