Error: can't read "TMPConfigHdr": no PolSARpro Geocode Parameter

Hello Everyone,

I am trying to geocode parameter in PolSARpro but I am getting the following error. Kindly guide me where’s the problem?


Hello, I have encountered the same problem, have you solved it? If you know the solution, please guide me, thank you!

in the first post an external DEM was used for geocoding. I guess, this caused the metadata error.

Do you also use an external DEM?

Yes, because my computer can’t connect to the internet, so I used an external DEM. I am using version 5.1.3. Can I geocode without the internet?

your external DEM must be a GeoTiff projected in WGS84 (EPSG:4326). Can you please check if this is the case?
UTM or other coordinate reference systems are not supported by SNAP (could cause the error in PolSARpro).

Ok, I check the projection, thank you very much.

Hello Braun and polsarpro guys,
When I imported the external DEM data as the following example, I also met a problem above mentioned.

I have checked the format of DEM data, with the WGS 84, not UTM or other coordinate systems.

Therefore, how to solve the problem occured in polsarpro geocoding?

Does it work with an automated DEM?
Please don’t forget to update SNAP as well to exclude all bugs.

The automated DEM of ASTER DEM can be worked, yet the SRTM can not. The SNAP has been updated to 8.0.

Please also install the internal updates (help>check for updates) because of this: A process related to digital elevation models is taking forever to finish

Great thanks for your reply! Braun
I have checked my SNAP to update 8.0.3, but when I used ranger droppler terrain correction, I can not import C11.bin. The error likes as the follows.

if you want to load PolSARpro data into SNAP, please proceed as described here: (17:26)

But you can also calculate C matrix in SNAP directly for many SAR sensors.