Error configuring Snappy (snappy-conf)

Dear colleagues and @marpet ,

The ./snappy-conf gives an error detailed at the following log:

INFO: Installing from Java module '/home/projetos/gustavo.ortiz/snap/snap/modules/org-esa-snap-snap-python.jar'
WARNING: Architecture requirement possibly not met: Python is x86_64 but JVM requires amd64
INFO: Installing jpy...
INFO: Extracting 'lib/jpy-0.8.0-cp27-none-linux_x86_64.whl' from '/home/projetos/gustavo.ortiz/snap/snap/modules/org-esa-snap-snap-python.jar'
INFO: Unzipping '/home/projetos/gustavo.ortiz/.snap/snap-python/snappy/lib/jpy-0.8.0-cp27-none-linux_x86_64.whl'
INFO: Configuring jpy...
INFO: jpy Python API configuration written to '/home/projetos/gustavo.ortiz/.snap/snap-python/snappy/'
INFO: jpy Java API configuration written to '/home/projetos/gustavo.ortiz/.snap/snap-python/snappy/'
INFO: Configuring snappy...
ERROR: Configuration failed
Traceback (most recent call last):
  File "./", line 262, in _main
  File "./", line 195, in _configure_snappy
    'java_max_mem: %s\n' % jvm_max_mem,
NameError: global name 'jvm_max_mem' is not defined

What should I change to properly configure it?



The error you see it says that you need to specify the maximum memory for snappy in the ‘snappy.ini’ file.
This file is usually located at your /home/.snap/snap-python/snappy.ini.
open the file and add the following:

snap_home =
java_max_mem: 30G

In terms of the memory, it depends on your computer. In my case, I set the max memory to be 30GB
I hope this will solve your problem

I think there are different versions of snappy involved in this error.
Maybe you better delete the directory home/projetos/gustavo.ortiz/.snap/snap-python before reconfigure snappy.
Then it should be possible to configure it again.

Now I’ve understood this problem.
Please have a look at this post:


which programm do you use to fullfill the change. If i change it to 30G (windows texteditor)and save the file and try to configure python the change is not saved and reset to 11G. I allways get the same error message:

I think the jvm_max_mem 11 G ist the problem.
I have SNAP 6.0 instaled.

This 11G should not be a problem. Nothing memory intensive is done during the configuration of snappy.
The 11G is coming from the file the etc folder of the SNAP installation.
I think there is something else wrong. Maybe with the ArcGis Python. Is this 32Bit or 64Bit?
What is written to the snappyutil.log file?

It is unfortunatly 32 bit. And it is complicated to get a 64 bit background environment from ESRI:)

In this case, you should install a second Python 64Bit. You can also try Anaconda or Miniconda.

its running on the 64 bit version with no problem. I want to use arcpy and snappy in the same script thats my problem.

I ran into similar errors.

It worked out for me when I separately installed python3.3 (made sure not to use python3.7), SNAP 6.0 and manually did the configuration (not during the installation of SNAP with the checkbox).