Error downloading DEM SNAP V7.0 in "Terrain Correction" step

Dear developers:
Hello, I find a error when I do the operator ----- “Terrain Correction” of Sentinel-1 GRD data on SNAP V7.0 (I use windows 10, 64bit systems ). It fail in downIoading the DEM all the time though I try many times. The error appears both on SNAP desktop and the gpt tool. When use SNAP desktop, error just like this:

It always repeat downloading the DEM file, and don’t do the actual task. (No matter I chose the SRTM 1sec DEM or SRTM 3sec DEM )
; When on the gpt, error like this:

It also just repeat downloading the DEM file, but always fail to get the DEM file.
However, I did can download the DEM file( using my browser by the URL (
I also found many previous articles about this error on the forum. But, I don’t find the riight solution to solve it. I also have other’s findings: sometimes it’s work right on SNAP V6.0 on windows 10 system and it work right on the Ubuntu 16.04 (Linux system).
I hope to get your reply and help. Thanks!
Yours truly,
Dahui Li

Update the version to SNAP V. 7.02, but I think this is not the problem try up to implement your graph without the step of TC. and then apply it separately. TC. causes problem within the graph, it’s also reported in other post, this thread for instance, Source of the thread

Thank you, sir! I have updated to SNAP V7.0.2. It did work right when take out of TC in the .xml graph. But,when I do the operator of TC separately, it stil get the error of downloading DEM repeatedly.

Althought it work well in Ubuntu 16.04 system. Also, I still want to know whether there is a solution to solve it, because I use windows10 system more often.

Please select SRTM DEM 1sec instead of 3sec,

Generally concerning the download, Maybe you need to configure the proxy settings. please take a look at this post,

Source of the post

Unfortunately the proxy settings are currently ignored by the DEM download functionality. The Update of SNAP works though.

Thank you, sir!
I decided to use SNAP V6.0.10, the previous version of SNAP V7.0. It didn’t have error of downloading DEM and worked well both in SNAP V6.0.10 desktop and gpt tool on Windows 10 system. Maybe I will try SNAP V7.0 when this bug are fixed.

Thank you again!
I have tried it, but it still failed. So I decided to use SNAP V6.0.10 and this error don’t happen again.

1 Like