Error during calibration

I am trying to calibrate a sentinel data and I am getting an error everytime. It says, A problem occurred during processing the target product processing. Type: OperatorException. Message: Calibration: java.lang.NullPointException

Kindly help me why I am getting this error and to get rid of this

I see you are using subsetted/cropped product. try using the original download (.SAFE). For the calibration the SNAP toolbox uses the annotation (LUTs) which follows a certain pixel pattern.

So calibrate first for the most accurate results, subset (do anything else) afterwards.

thanks for the reply. But I tried calibrating the entire image, but I got the same error. Please help

I believe this problem has been fixed. Are you using version 2.0 not the beta?
Try with the original product without renaming it.

I am using version 2.0 I tried using the entire image without renaming it. Still I am facing the same problem. Is there anything that I am not following properly? kindly help

I am using version 2.0 I tried using the entire image without renaming it. Still I am facing the same problem. Is there anything that I am not following properly? pls help

Well one more thing comes to mind, check if have downloaded the complete product. Recently the sci.hub was undergoing major maintenance (regarding launch of S2 data, new interface, apihub,…), so there might have been a connection error while downloading.

Check for the size of the download should be slightly above 1GB at GRDH, if it is not the case re-downlaod your product.

Otherwise try a different time series. And next time provide us more accurate log of how are you processing the products step by step.

ya the website is temporarily busy. So, after the data becomes available, I will download them and let you know. Thanks for your reply.

Dear all,
Today I again tried downloading sentinel 1 Data product. As an initial step, I tried to calibrate the product without subsetting. This time, I didn’t get error which I was getting earlier as I had posted in my previous posts. This time I got the output, kind of partially. I tried to save the output this time as .tif file format.
I’m sending the screenshots of the steps I performed. The entire product size is 1.82 GB.

I opened the file

The calibrated output I got is as below:

kindly help me where I’m going wrong. Pls help!!!

Dear All,
I’m sending the entire image I used for calibration.

I have encountered this issue myself.

I do not know why in your calibrated output are two bands, you should be calibrating one band at a time.

Else you will be having or are having memory error which could be in the setting of the java virtual machine in the SNAP settings.

Example for a 16 RAM machine and it can handle the calibration.

Dear All,
Every time I’m facing unique errors. Now my calibration is working and I did speckle filtering on the image.

when I do the terrain correction (range doppler terrain correction), I’m getting only a little of the image as output.

Kindly let me know, during speckle filtering, I have the entire scene but after terrain correction, the image I’m getting is only a very small portion of it. Kindly explain.

That could indicate a problem with downloading the DEM.

1 Like

Does that mean the full DEM was not downloaded ?

That is what it could mean. It’s also possible to download the DEM manually into a folder but I don’t have the details on what the required steps are. Have you consulted the help?

Ok. I will try downloading the DEM manually.Also, I will look into the help.

I doesn’t look like the problem is with the DEM. From the images you provided, TC seems correct for the region shown on the map. The question is why is product [2] so small after multilooking? What has happened between [1] and [2]?

1 Like

Now, I got the output perfect. I don’t know why, but I tried doing the entire process again and this time I got the output. Thanks for your replies.

When the sentinel data hub will be available again? I,m getting this message since 3 days.