Error during the target product processing

Dear forum;
I am a begginer in sentinel toolbox. I downloaded this image:

Then, I wanted to apply the radiometric calibration: Radiometric/calibrate. However , I got the following error:
SNAP - Error
"A problem occurred during the target product processing.
Message: Not able to write product file:
‘C:…\S1B_IW_GRDH_1SDV_20170305T103823_20170305T103848_004572_007F86_4C55_Cal.dim’ "

Even though I renamed the file (a shorter name), I got the same error.
Please Could you help me?

PD: I got the same error even if a change the image (for the same area e.g. S1B_IW_GRDH_1SDV_20170329T103823_20170329T103848_004922_0089AE_1AB7 )

Which version of SNAP do you use?

What are the properties of your Machine? (RAM)

Take a look at this post explains , the calibration,

Also at this post

Hello falahfakhri;
Thanks for your reply, I have the SNAP 6.0.0. , 16 GB of RAM. I solved the problem (memory issues with in my laptop) . However, I have more issues: after the radiometric calibration I applied the "speckle filtering/ single product speckle filter. I run the process with all the parameter by default.
There is not errors during the process but the final product has a zero histogram. I repeat the process several times but nothing changed.
To summarize:
S1B_IW_GRDH_1SDV_20170305T103823_20170305T103848_004572_007F86_4C55_Cal_Spk : I got the sigma null (nice results)
S1B_IW_GRDH_1SDV_20170329T103823_20170329T103848_004922_0089AE_1AB7_Cal_Spk_TC: after the speckle filter the results is bad, no histogram, zero values for sigma null.
Thanks for your help.

I think this simple video helps you to understand your steps,

Also have a look at this post,