Error in creating L2A User Product( (sen2cor 2.4.0)

Hi there,

I have a problem with “old” S2-Data and Sen2cor processing.
I used the file S2A_OPER_PRD_MSIL1C_PDMC_20160117T121107_R112_V20160116T172531_20160116T172531.SAFE

The file is located on a server and the input path starts for example with \\server00190\Sentinel-2…

Then sen2cor prints the message
"Sentinel-2 Level 2A Processor (Sen2Cor), 2.4.0, created: 2017.06.05 started … "
and then stops with no Error message. In the log file I can simply find “Error in creating L2A User Product”

As stated in this post Error in creating L2A User Product (sen2cor 2.3), the error is raised because there are two folders missing (AUX_DATA and HTML). But i have these folders included.

Then I tried to shorten the filename to simply " S2A_OPER_PRD_MSIL1C_PDMC_20160117T121107" but still it doesn’t work.
Then I copied the data to a folder on my computer to c:/ and suddenly it worked (even with the shorter filename).

Is it possible that sen2cor has problems with server/network paths?
However, what I don’t understand is, that I was able to process"new" S2-Data S2A_MSIL1C_20170110T171651_N0204_R112_T14SPJ_20170110T171653.SAFE from the network. So what’s the problem with the old naming and sen2cor?

Thank you in advance!


The issue here is with the extraction of your folder.
Because of the long folder names, extracting in windows doesnt always extract the files or folders properly.

Try using something like 7-zip, as this will overcome this problem (I hope!)


Hi Will, thanks for your answer.
But I don’t think that this is the problem because the data can be processed when it’s located on my computer (e.g., c:\s2_files…) but not when it’s located on a server (e.g. \\server00190\s2_files…).

So the data is correctly extracted, otherwise sen2cor wouldn’t work on a local file.