Error in http retierve

I get the following error now,

SEVERE: org.esa.snap.core.dataop.dem.ElevationFile: java.lang.reflect.InvocationTargetException
INFO: org.esa.snap.core.dataop.dem.ElevationFile: http retrieving


Access Denied



I get the Access denied when I try to open.Could you please help ?

Please check if you installed all updates, because this should have been solved since version 8.0.3.
The location of SRTM 3Sec has changed.

Hi Braun,

Thank you. Please let me know where i could download it ?


You can check under Help > About SNAP which version is installed.

If you want to go sure, please

  1. download the lastest version (SNAP 8) here:
  2. Install all updates (you are notified with each startup of SNAP, otherwise you find it under Help > Check for Updates).

Hi Braun,

I tried to run the updates using command line in Kubernetes cluster and I see there any 95 updates available. But the updates fail with the following error

Exception in thread “main” java.lang.Error: Probable fatal error:No fonts found.
at sun.font.SunFontManager.getDefaultPhysicalFont(
at sun.font.SunFontManager.initialiseDeferredFont(
at sun.font.SunFontManager.findOtherDeferredFont(

It also breaks the snap installation. I have configured snappy with python 3.6 and followed this documentation to run the updates

Many “headless” environments are configured without fonts (e.g., by IT staff labouring under the misconception that you only need fonts in a GUI). In practice there are use cases such as generating labels in PNG images that need fonts.

Using Fonts with OpenJDK describes ways to add fonts to a “headless” environment, either by adding linux distro font packages or pointing Java to a directory of fonts you have created.

Hi GN,

I am not able able to install the fonts since I am not root user. Either I am able to create a folder for fonts and add it the fonts.

Any other ideas here ?


The folder can be in your own directory. If your access doesn’t allow you to create your own folder you won’t be able to do much with SNAP. You may need to ask the manager of the system for help.

Where can i download the TF files and how I do i configure it ?

The examples suggest “dejavu” fonts. The just follow the directions for using a custom font directory. They give you a new entry for the Java command-line.

Hi GN,

I have downloaded the devaju fonts in my local dir and tried to configure it using java command line using -Dsun.java2d.fontpath=MYFONTDIR. But this does not seem to work . Could you please help here ?

You have to provide more details of what you have done. Please show us (in text format) the result of ls -l MYFONTDIR. What does

mean? Did you add the option to <snap_install_dir>/etc/

I have already set it in the


Still I get the font errors…Could you please help here ?

You have posted images, not text (and using low-contrast colors that are very difficult to read on this laptop). It looks like you have

-Dsun.java2d.fontpath<space>=<space>MYFONTDIR (e.g., with space characterss around the =).

Try removing the two space characters.

When working with SNAP software you have to be careful with spaces and “look-alike” characters. Posting text makes it possible for others to detect problems that are not visible in screen captures.