Error in running mt_prep_snap. "slc.par" and "matlab: Command not found."


In the process of selecting PS points and unwrapping
After overcoming many problems, I got stuck in another place again.
What is /media/eos/703815B938157EF2/7_psiexport/0.4/*slc/20200407.*slc.par: There is no such file or directory.
and
matlab: Command not found.
ls: Cannot access’/media/eos/703815B938157EF2/7_psiexport/0.4/ slc/ .*slc’: No such file or directory
Why~~~~~~~~~~~~~~~~~~
I have been trying to deal with it for a few days and it has not made any progress at all.
I have also read articles from other people’s questions, but I have not found a good solution.
Please can anyone help me!!!

please try mt_prep_snap 20200407 media/eos/703815B938157EF2/7_psiexport 0.4 3 2 50 200


I get similar results :sob:

no slash here

grafik


still the same :tired_face:
Hope you can help me, thank you very much!

What do the messages say?

It said that there is no such file or directory.

Where exactly did you put the files you exported from SNAP?

The file and folder structure seems to be not correct.

Have you seen these?

Thank you for your help, I finally deleted some files that ran out of the previous error from the psi folder. After leaving only the original four files of dem, diff0, geo, and rslc, use your recommended grammar to execute and run successfully. Thank you very much! (The success screen is shown below)

But I encountered a new problem :sob: :sob: :sob:
I opened matlab and executed stamps(1,1), stamps(2,2), stamps(3,3)…
But an error occurs in stamps(6,6), as shown below.


I tried to find a solution,


For example, I found someone who had the same problem as me, read this reply, and tried to create environment variables as he said.
But the problem is still not solved.

Is there any other solution
I need your help!

what happens when you enter snaphu in your shell (after sourcing the StaMPS config file)?

Thank you very much,
I found that my snaphu installation is not complete
After reinstalling, successfully ran stamps(6,6)
thank you very much!!

1 Like

very good - congratulations on comiling snaphu in Linux!

I ran into the same problem,I did it according to your idea, but it still didn’t solve it. When I did 6 interfering pairs before, I could ran mt_prep_snap normally, but this time I did 20 pairs and the preprocessing failed.

Can you tell me in detail how you solved it?

Have you tested a different number of tiles?

Dear ABraun, I tried the ‘mt_prep_snap 20180709 /home/sun/export 0.4 5 5 50’ and then still showed me ‘home/sun/export/*slc/20180709.*slc.par: no such file or directory’

Dear ABraun,this time I directly used the data from the external media,and commend 'mt_prep_snap 20180709 /media/sun/export 0.4 5 5 50 50,then it run normally but slowly. Did I make a mistake when I copied the data?

This is hard to tell. In the end you always need a clear structure. One export folder with dem diff0 slc and geo and another directory where you execute mt_prep_snap and all the matlab files are generated. When you mix them you are likely to mess up with the file structure.
The best you can do is closely follow the steps provided here: StaMPS/2_stamps_workflow.md · master · Matthias Schlögl / gis-blog · GitLab

Thanks for your reply! and I will follow your links.