Error in SNAP-resample of Sentinel-2 S2A data.

Error in SNAP-resample of Sentinel-2 S2A data.
① In Windowns PowerShell, run the command
"for /r" F:\111\0220 "%X in (*.zip) do (GPT resample-ssource =% x-t". F: \ 111\0220 \ Resample \ % ~ nX_resampled dim").
There was no response.
② In the CMD window, run the command
"for /r" F:\111\0220 "%X in (*.zip) do (GPT resample-ssource =% x-t". F: \ 111\0220 \ Resample \ % ~ nX_resampled dim").
Error: Operator ‘ResamplingOp’: Mandatory sourceProduct (field ‘sourceProduct’) not set.

Your command is not well formatted. At some places spaces are missing and in other places there are to many. And some other issues.

For example:
resample-ssource = % xresample -SsourceProduct=%X
and
x-t". F: \ 111\0220 \ Resample \ % ~ nX_resampled dim")X -t "F:\111\0220\Resample\%~nX_resampled.dim")

This guide gives an introduction to batch processing from the command line:
Bulk Processing with GPT - SNAP - Confluence (atlassian.net)

Ok, I’ll try to normalize the command, thank you.

Hello, I’m back, modify Settings command run successfully, thank you.

1 Like