Error in SNAP - StaMPS processing of RS2 data: "Index in position 1 is invalid"

I am not worried at all, i would like to contribute!

I just wanted to make sure you didnt think i had the solution for the cygwin StamPS compiling because lots of people struggle with that.

I also read something about the StamPS SBAS processing being developed, do you know of any progress on this topic? @ABraun

yes, I also think this makes more problems than it solves. But I saw cases in here where this worked as well, so I’m open. Preparing PS InSAR Sentinel-1 products for the processing with Linux/StaMPS is still a topic of large interest.

About the SBAS thing: SNAP is not able to process multi-baseline interferograms at the moment. Some workarounds are being developed but none of them is official so far.

1 Like

when i have a draft on the readme file i will send it to you or share it on the forum.

Yeah the workaround is what i meant, do you have any clue if this is working yet or who is working on it?

I have no overview on that, sorry.

I carried out the preprocessing in windows environment… I completed upto stamps export… Does this mean that i need not install snap or python in linux…??

Kindly clarify please…

Now i have the stamps export files, and i am double booting my linux os with ubuntu 18.04.2… After this what software should i install?? Is there any changes from the actual installation and configuration procedure?

have you seen this post? About the STaMPS category
Many things are explained there already very well.

You need a linux environment, install matlab and StaMPS, as well as triangle and snaphu. You will find the instructions in the StaMPS manual:
As you prepared the data in SNAP, you can then start the processing in chapter 4.

If you have specific questions, feel free to ask. But there are already several point-by-point information on what is required to run StaMPS and how to do it, so please try to start based on them first. It takes some reading though.

thank you @ABraun… Then do you mean that there is no need for me to install python and snap in the linux environment… Only matlab, stamps, triangle and snaphu will do?? after installing these are there any specific configuration steps to be carried out or could i jump directly to the chapter 4?

yes, python and SNAP are no longer needed.
You can then start in the linux shell with mt_prep_snap as explained by Gijs here: How to prepare Sentinel-1 images stack for PSI/SBAS in SNAP


okay done… Am happy about it… Will let you know if i face any issue… Thanks a lot…

As @ABraun mentioned you indeed dont need python and SNAP anymore, thats the reason i recommended you to use Windows.

Folow the installation steps @ABraun just gave you or follow the step by step instructions in the gitlab markdown i send you. It will become clear for you soon!

1 Like

Sure @Gijs… thank you for your response

could anyone tell me installation procedure for installing matlab R2017b_glnnxa64_Linux.rar in ubunti 18.04.2…
I am new with linux… Kindly help

I have always used this documentation

how to unzip rar file?

no offence meant, but this is nothing remote sensing specific and could easily clarify with a short google search. :slight_smile:
People who are here to help others mostly do this in their free time and are happy to be able to help anyone who has problems, but it is not their duty to give basic computer tutorials. A bit of self-study should be reasonable :+1:

i dont mean such… i actually installed unrar and then found problems in installation… Thats y asked whether there are any other means… i went through so many files regarding installation but getting errors in all… so i asked here… Sorry for the inconvenience… @ABraun

no need to apologize. Just a reminder to ask more specifically so people can give you a concrete advice.

This is the problem i am facing… Could anybody tell me where i have gone wrong? @thho

I have other problem of license in VM, I feel of you,

First thing,

unzip your matlab using cmd, in different folder not the target one, when you want to install it,

cd to the directory where is the zip and then,


Next step,


You’ll get the GUI of installation and proceed with next until reaching the confirmation

if i unzip using cmd i get total error: 1

then even if i give install i am getting the same error as earlier…