Error in sub setting the image with a shape file

I have edited the xml provided by marpet for subsetting the S1 image and my question is

  1. Is MULTIPOLYGON is acceptable as a georegion in GPF?
    when i tried to excute this xml the following is thrown.

gpt E:\Try\SubsetS1.xml -t E:\Try\S1A_IW_SLC__1SDV_20150727T003129_20150727T003158_006989_0097BF_B5BA_Subset.dim E:\Try\S1A_IW_SLC__1SDV_20150727T003129_20150727T003158_006989_0097BF_B5BA.dim
INFO: org.esa.snap.python.gpf.PyOperatorSpi: Python operator ‘S2RutOp’ registered (Python module: ‘s2_rut’, class: ‘S2RutOp’, root: ‘C:\Users\SAIPLANNER\AppData\Roaming\SNAP\modules\org-esa-snap-snap-rut.jar’)
INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external tool adapters
Executing processing graph
INFO: org.hsqldb.persist.Logger: dataFileCache open start

Error: [NodeId: Read] Specified ‘file’ [${sourceFile}] does not exist.

My source file is located in

The edited xml file is shown here:

have a look at the solution provided by marped, here: Doesn't take specified source in gpt

You must remove the Read node and change the subset node accordingly.

Either changing the graph as ABraun said or specify the source product as follows:


Thanks marpet it worked.