Error in Supervised Classification

While performing the supervised classification of an image (using Random Forests, KNN KD Tree NN), I am getting the error java.lang.NullPointerException. Please help.

1 Like


Not an answer but the issue was already mentioned (and apparently solved) a while ago. Let’s see what’s happening in your case

hi, have you solved that issue?

Hi, did you resolve the problem? I have the same like you but I do not know how to continue

it has been reported several times that classificaton of Sentinel-2 or Landsat products (geocoded in UTM) only worked after reprojection to WGS84

Thanks for your answer.

Dear sir ,I had the matter again ,when i classfied the sentinel-2 with the RF and i had reprojected,however the result was empty,like this picture:

please hlep me soon.thanks in advance!

the feature importance indicates that you only selcted B12 as input. Please run again and select all optical bands as “Feature bands” for the classification

Please how did you correct this error, I need help ,I am having the same problem.

please first describe your raster products and training data, which operation you applied and which error message you received.