Error messages after installing SNAP

Hi forum

after installing SNAP 5.0 in Lubuntu 16.04 64bit and launched the software I get two error messages

File autoupdate in Default System is read only
File Windows2Local-hidden in Multi-Fylesystem is read only

I presume that is due to file permission, but where are these files?

Thank you very much

Did you have a previous version of SNAP? Did you install or run as “root” user(e.g., using “sudo”)?

Why I ask: netbeans bugzilla 134243: “If the IDE is run with root privilegies [sic], files under Userdir/config/Windows2Local/Modes are created or modified with root ownership. Then if the IDE is run with user privilegies, the files cannot be changed and exception is thrown. I changed the code to not throw such confusing exception.”

Have a look at permissions in “$HOME/config


I installed SNAP with

sudo bash

I solved the issue of “File autoupdate in Default System is read only” by giving all the permissions to my
/home/giacomo/.snap/system/config/Preferences/org/netbeans/modules/autoupdate folder.

I’m still getting /Windows2Local.

I don’t have a /home/giacomo/config, but I have /home/giacomo/.config.

I also gave permission to /usr/local/snap but I didn’t solved

Thank you

Hi I solved adding this line in my /home/giacomo/.bashrc

export PATH="/usr/local/snap:$PATH"

Thank you

Using sudo to install SNAP is the reason you are having problems. If you found instructions such as those at GIS blog suggesting that you should ask the author to correct them so others don’t get caught out. (I have already added a comment at GIS blog).

You might be able to recover by changing ownership of the full snap and .snap trees (e.g.,sudo chown -R <user>:<group> ~/.snap ~/snap), but the most certain fix is to delete those directories and their contents (using sudo) and reinstall without sudo.

That’s very tricky

Sorry, in your stetment USER is me (giacomo) but the GROUP ?

so it is a netbeans problem during installation?

Anyway it seems that I solved.

Now I’m only having a problem with the browser and I’m gonna post another topic

Thank you

HI again

you were right

I uninstalled and installed again without sudo and it works

Thank you so much