ERROR - "No appropriate product reader found"

Hi, I have just installed the SNAP package, and I have trouble loading S2 data (ERROR - “No appropriate product reader found”). I am totally new to these tools so I do not have a clue as to how to try to fix it smile: I have read different posts to try to get some tips, but I doesn`t work (installed latest version today, and “checked” S2 toolbox during installation). Help is needed wink:

You have to open the xml file to open the S2 product and this file shouldn’t be renamed as the reader selection is done with the file name. Is it what you’re doing?

Hi, I have tried to open several products, e.g. S2A_OPER_MTD_SAFL1C_PDMC_20160209T184130_R094_V20160204T110240_20160204T110240.xml, every time I get “Failed to parse metadata”. I read in another thread that it might be because of a corrupted product, but I have tried several. Any idea what to do?

Could you send us the xml file so I can try to load it? Thanks in advance.

Sorry for the mess above. It looks like I have troble uploading to the forum. Is it possible to send via email?

There is an “Upload” button just over the editing window when you reply on the forum. Do you have problems with it? If this is the problem you can indeed send it to me by email.