"Error: [NodeId: Apply-Orbit-File] error in opening zip file"

I have been getting this error when applying ‘Sentinel Precise’ orbit file during S1 TOPS Coregistration. Additionally under the TOPSAR-Split and TOPSAR-Split(2) headings no subswaths are selectable (i.e. the drop down menus are blank). If anybody knows of any fixes that would be greatly appreciated.


It could be that it didn’t finish downloading an orbit file properly and now you have a corrupt file but it can’t download a new one to replace it. Try finding out which date you may be using and manually delete it then try again and it should download a new one.

1 Like

Thank you, I will try that. Where can I manually get orbit files from?

Hi, I have been working with Sentinel IW images for a while now and it has been smooth so far. But lately, for every image I download, the “Apply Orbit File” function gives this error everytime. I have downloaded the whole dataset again, but to no success.

  1. Why is this problem recurring lately?
  2. I am not able to understand which ‘Orbit File’ file to choose while downloading manually. Could you also please help me with a reference to that.
  3. Once, I am not sure if I downloaded the correct file, but I downloaded a Orbit File based on the ‘Sensing Date’ and put it into the mentioned folder, still the same error popped up.

Please help! Thanks.

Have you updated SNAP with all the module updates?

I did all the updates after your reply, and it still doesn’t work. The same error pops up “Error: [NoteID: Apply-Orbit-File] error in opening zip file”.

I have tried it on 2 different PCs.

I was initially working with these 2 scenes

Later, I also downloaded

But all have the same problem, ‘Error in opening zip file’
Can you please suggest me a way around this?

It sounds like it downloaded something but then can’t open the zip file. Maybe the download was interupted and the file is corrupt. If you can determine the orbit file from the date, try deleting it from the .snap/auxdata/Orbits folder and then try again. It should get a new file.

Thank you for the response. I am now sure that there is some problem with the ‘AUTOMATIC’ downloading of Orbit files.

These are the steps I did:

  1. I followed the designated folder where precise orbit files are stored in my system and found a orbit file that was downloaded.
  2. The size of the file was 3kb. This was an indication that something was wrong.
  3. I deleted the file and reprocessed the image.
  4. Same file downloaded whose size was 3 kb again.
  5. I went to the Sentinel Quality Control website and downloaded the precise orbit files ‘MANUALLY’. Size - 4.5 mb.
  6. Placed the file in the designated precise orbit file folder in my system
  7. Re-run the ‘Apply Orbit File’ function or ‘S1 TOPS Coregistration’. Works perfectly now.

While I have found a way around, what could be the problem with automatic retrieval of Orbit Files?

I had the same problem but following your steps, I succes the corregistration applying orbit files manually.

Thank you.

can you guys tell me how to download the orbit files manually?