ERROR:'NoneType' object has no attribute 'GetRasterBand'

Do you have any idea what this error is when preparing the ERA5 reanalysis surface meteorological data (ERROR:‘NoneType’ object has no attribute ‘GetRasterBand’)?
I downloaded the ECMWF ERA5 file normally.

What should be done?

And now I cant open the S2 product. i am receiving this error.

Hello @abeddoughan,
Deleting <user_directory>\ .snap\auxdata\gdal and restarting SNAP should fix your problem.
If it still doesn’t work, please attach the messages.log file (use “Help" → "Show Log Directory” menu to find the log).

1 Like

hello diana thanks

you mean this file only? Will other products tha i processed (working on SEN-ET so fraction of green vegetation, daily ET, net shortwave radiations, preprocessing outputs etc…) be affected?

Yes, this is the folder you have to delete. It will be recreated by SNAP when you will open the first S2 product. None of your previously processed products will be affected.

1 Like

Thanks Diana!
Much appreciated. It worked

Now i know what to do in case similar thing happens in the future (God forbid I hope not :sweat_smile:)

a problem im facing is that I am pressing the aerodynamic roughness (not only this but other processes too) and the tab isnt opening.

Any idea?

Checked with SNAP 9.0.6 and the latest SEN-ET version downloaded from
The “Estimated aerodynamic roughness” window opens.

Is there any error in your log file?

1 Like

it worked again. in case it malfunctions, ill redownload this plugin.