Error: openjp2 library

Good afternoon everyone,

I had to reinstall my anaconda and sen2cor/sen2three.

I have now again an old (?) issue:

Microsoft Windows [Version 10.0.10586]
© 2015 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Users\Andreas>L2A_Process --help
C:\Anaconda2\lib\site-packages\glymur\ UserWarning: The openjp2 library at C:\Anaconda2\Scripts\openjp2.dll could not be loaded.
warnings.warn(msg, UserWarning)
C:\Anaconda2\lib\site-packages\glymur\ UserWarning: Neither the openjp2 nor the openjpeg library could be loaded.
Traceback (most recent call last):
File “C:\Anaconda2\Scripts\”, line 11, in
load_entry_point(‘sen2cor==2.2.1’, ‘console_scripts’, ‘L2A_Process’)()
File “C:\Anaconda2\lib\site-packages\setuptools-27.2.0-py2.7.egg\”, line 565, in load_entry_point
File “C:\Anaconda2\lib\site-packages\setuptools-27.2.0-py2.7.egg\”, line 2598, in load_entry_point
File “C:\Anaconda2\lib\site-packages\setuptools-27.2.0-py2.7.egg\”, line 2258, in load
File “C:\Anaconda2\lib\site-packages\setuptools-27.2.0-py2.7.egg\”, line 2264, in resolve
File “C:\Anaconda2\lib\site-packages\sen2cor-2.2.1-py2.7.egg\sen2cor\”, line 13, in
from L2A_Schedule import L2A_Schedule
File “C:\Anaconda2\lib\site-packages\sen2cor-2.2.1-py2.7.egg\sen2cor\”, line 11, in
from L2A_ProcessTile import L2A_ProcessTile, SUCCESS, FAILURE
File “C:\Anaconda2\lib\site-packages\sen2cor-2.2.1-py2.7.egg\sen2cor\”, line 14, in
from L2A_AtmCorr import L2A_AtmCorr
ImportError: DLL load failed: %1 ist keine zulõssige Win32-Anwendung.

Installation worked well and without errors: I reinstalled Anaconda (Python 2.7.12, Anaconda 4.2.0 (32-bit), 29th June 2016) and then sen2cor.

Did anyone experience the same issue?


Good morning,

I solved the problem. By accident I installed the 32-bit Version of Anaconda. When the 64-bit Version is installed, everything works fine again.